Ikchains that are here to fuck up your day.

Today i tried to make a playermodel.
And i wanted ikchains because without them revolver reload animation is broken af
But every time i put ikchains in the qc
The legs were twisted 70.7 degrees to the left. on the hips.
And then i tried doing different things like:

  • twist the legs -70.7 degrees left in blender (did not work)
  • disable the hands ikchains (results in crash)
  • disable all ikchains and re-enable them (yup, it didn’t do shit)
  • set all values to 0.000 (instead of 0.707) (yep, they were STILL at 70.7 degress) ($ikchain rfoot ValveBiped.Bip01_R_Foot knee 0.000 0.000 0.000)
  • remove bodygroups
  • reinstall crowbar
  • reinstall gmod
  • reinstall windows
  • purge hard drive
  • compile with source sdk 2013 (no difference here)
  • compile with sfm (didnt even work, just crashed)
  • compile with tf2 (same as sdk)
  • use another working model’s qc
  • use a qc of earlier (working) version of the model with ikchains (yes they fucked up for no reason after i did not touch them) (only modified some finger bones because they weren’t straight)
  • write a new qc
  • steal a qc off the workshop
  • use kleiner’s qc
  • iklocks
  • autoplayiklocks
  • hiring 2 employees who also tried numerous things
  • 41 other things or the same things repeated that i don’t remember anymore

and then after 65 compilations, 10 hours, a kick from TFA’s Discord, a bluescreen, and a 4chan thread
i came here.
hoping that somebody would finally help me.

TL;DR: Why do ikchains make legs twist left?

P.S.: and after the 66th compilation the right hand went left as well (i’ve just rewritten the qc line)

EDIT: some screenshots:


(User was banned for this post ("Wrong Section - try the modeling section next time" - Kiwi))

Hmm. Well that’s basically exactly how I set up my QC except I don’t use the quotation marks. I can’t say I’ve ever had an issue with it.

In that case I’d guess it’s not because of the QC, and my first thought would be to reset/apply the object transforms in the 3D application and see if that fixes it. That always seems to be the cause of a bunch of problems.

Good luck, man

Edit: Oh and here’s one of my QCs if you want to give it a try. https://www.dropbox.com/s/1o7izjlj88jwf8f/count_chocula.qc?dl=0

I don’t do an iklock on the ragdoll sequence, so that might be it too.

Just tried applying all transforms in Blender, sadly did nothing…
Also removed iklock from the ragdoll sequence as in “why would it help if it activates on the ragdoll?”

Ah that’s a shame. Well if you still can’t figure it out, add me on Steam and I’ll help you mess around with it a bit. I’m sure we can figure it out if most everyone else isn’t running into the problem.