In game voice doesn't work.

Hey guys.
I purchased rust today but my in game voice doesn’t work.
Some info:

  1. I’ve tried rebinding the voice key
  2. My mic works on both skype and every other game
  3. I’ve restarting both Rust and my computer
  4. When I press F1 it does say the right microphone

Anyone help would be great, thanks
-Lachie

Check your steam option settings and see if its using your correct mic or if you have a webcam connceted it could effect which is your default mic.

I checked it, and its the right one.
Also, I have an inbuilt webcam (i have a laptop)

I would just leave your ingame voice key to v. Also, the chat isn’t global. Only players literally like 10 feet away from you can hear you in game.

I have a mate with me who cant hear me. He can hear others though.

Idk, the only troubleshoot I can give is…

  1. Make sure mic isnt muted
  2. Shift+Tab -> Settings -> Voice tab and make sure correct Mic is chosen, do a test voice to make sure.
  3. Make sure your default mic in control panel selected is the correct one
  4. Leave the default voice key alone
  5. Make sure the actual mic plug is in a mic slot and is pushed all the way in

If you go through those 5 steps it should work, and if it doesn’t you’re overlooking something.

My mic on other steam games. It’s rust that’s stuffing up.

There were few people who had troubles with keybindings. I would suggest going to your Rust’s config file and open it with notepad and change the keybinding there to “V”.

It says V

[editline]14th December 2013[/editline]

mine says “noneinput.bind voice v”

When you go to steam settings and do the “Test Voice” option, is it picking up any sound?

yes