Incompatable Versions

This Morning I had a rust update… I updated… I tried to get into my hosted server… disconnected imcompatable versions… So I login to my host and install the update and I still cant login to my server… still says incompatable server…Do I have to wipe it after every update???

yes m8 needs steam update

[editline]25th October 2014[/editline]

i always do clean install

I updated server and my steam… Shouldnt be incompatable

[editline]25th October 2014[/editline]

every update something breaks

I am also having this problem :frowning:

mine works fine

What is your steamcmd command to download/update the server?

Does it include -beta experimental or -beta anything-at-all?