Incompatible Version for server problem

I haven’t had this problem before but i have seen other people have had the problem. I checked other forums and things of that nature and tried out what they suggested to do and nothing worked. I can join ever single server except for one. That one server is my friends server, i have yet to join that one but i really want to play with him. Anyone suggestions from anyone will be hopefully helpful.

They haven’t updated to the most recent version of the game yet.
Hence “Incompatible version”

The thing is my friend has updated and I have updated but my friend can join.

Are you accidentally opted into the dev version in steam?

Or, is your friend using the dev build and you aren’t?

No I haven’t messed withe the dev version, I asked him and he isn’t using the dev version either