Indoor basic lighting

Without any light entities map is completely dark. Is there option to change that? I have huge indoor map and adding 1000 light entities would be bad, at least to my mental health.

Screenshots of the indoor area in question please…

http://img171.imageshack.us/img171/8963/mapwips.jpg

There are many corridors like this and couple larger rooms…

light_spot with lights will be fine for that.

Also I suggest you read up on basic source level design, your map seems to be incredibly blocky and not very detailed at all.

Maybe because its not done yet :stuck_out_tongue:
Thanks.

Adding onto what sphinxa said- you are using wall textures on the ceiling (bad) and combine architecture uses much more slopes and stuff.

IF you dont like the whole lighting thing. Looking into texture lighting. Create a func detail light with some of the texture lighting texture on it and place is round the place.

The other guys are right you need to look into decorating the place.

Place an extra layer of wall over the current 1. Use pillars, pipes and wire meshing to hide the old wall. This extra layer of 3d will make it look less like a wall and more like a WALL.

That’s not really an excuse at all my friend.

Try watching some tutorials:

http://www.youtube.com/darkironphoenix
http://www.youtube.com/mappingfiregod

Text tutorials are here:

http://www.halfwit-2.com

Add 2-8 light entities spread evenly throughout large indoor area, change the quadratic falloff multiplier to 0 (that’s the one that causes most light to be almost nil before even a reasonable distance has been reached).
Try setting either linear or constant (but not both) to 1.
One important thing to remember with doing this though is that light will travel much further than you’re used to when using these different falloff multipliers, so you may find yourself using much weaker light settings than what you’re used to and even then probably getting too much light.

Make sure most are tinted slightly blue to match the Combine theme! :eng101: