Ingame model works, material not found.

Basically, material for model does not work at all, after everything i’ve tried.

.vmt is in:


C:\Steam\steamapps\##\garrysmod\garrysmod\materials\models\kamina2

and models are in


C:\Steam\steamapps\##\garrysmod\garrysmod\models\kamina2

.vmt contains:


"VertexLitGeneric"
{
	"$basetexture" "models/kamina2/kamina2"
	"$surfaceprop" "metal"
	"$model" 1
}


and the .qc used for compiling contains



$modelname		"kamina2/kamina2.mdl"
$body mybody	"kamina2.smd"
$staticprop
$surfaceprop	"metal"
$cdmaterials	"materials/models/kamina2"
$scale			1

$sequence idle	"idle.smd" loop fps 1

$collisionmodel	"kamina2-phy.smd" { 
	$automass
	$concave
}

$keyvalues
{
   "prop_data"
   {
       "base"  "Metal.Medium"
   }
}


Please tell me where i went wrong?

“$basetexture” “models/kamina2/kamina2”

remove one of them kamina’s and it should work,
so it should be: “models/kamina2”

Alright thanks, will try it in a few hours, see if it works

It should be


"$basetexture" "models/kamina2/kamina2"

in the .vmt, and


$cdmaterials	"models/kamina2"

in the .qc.

Also, next time, test the model in Model Viewer, then ingame. Model Viewer lets you pick up physmodel, texture, and .smd problems, while ingame then lets you find any other errors.

tried both of these, did not work.