Insane Rust Lag

hi i have rust and it runs insanely bad. my specs are not the problem i have a NVIDIA Geforce GTX960M (2GB)
12 gb of ram
3.5 GHz Core i7-4720HQ
also my connection is not the problem as I get around 80 ping on most servers

Right-click on your desktop and set your default graphics adapter to be the 960M. I almost guarantee Rust is using your Intel HD Graphics.

how exactly do I do that?

In your taskbar, lower right, you’ll want to find your Nvidia logo and right click it and hit Nvidia Control Panel. Then go to manage 3d settings and select High-performance Nvidia processor in the Preferred Graphics Processor.

thanks!