Installing steamcmd and whatnot 32bit librarys so it can run on ubuntu 64bit? 14.04

I’ve been trying to install steamcmd and do servers etc. but im missing the 32bit library files and what not? I’ve tried everything.

Sorry that I’ve been asking for alot of help recently. Anyway how would I do this? I’ve tried this.
Building dependency tree
Reading state information… Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
lib32z1 lib32ncurses5 lib32bz2-1.0

E: Package ‘ia32-libs’ has no installation candidate

I tried installing all three of these too lib32z1 lib32ncurses5 lib32bz2-1.0

EDIT- I tried this too

apt-get install lib32gcc1

Try using:

Or create a start.sh file containing this:

I tried using apt-get install program:i386 but i get this
apt-get install program:i386
Reading package lists… Done
Building dependency tree
Reading state information… Done
N: Ignoring file ‘ia32-libs-raring.lis’ in directory ‘/etc/apt/sources.list.d/’ as it has an invalid filename extension
N: Ignoring file ‘ia32-libs-raring.lis’ in directory ‘/etc/apt/sources.list.d/’ as it has an invalid filename extension
E: Unable to locate package program

and I think i made and ran the file… but I dont know, Im a noob at linux

[editline]23rd October 2014[/editline]

NVM FIXED