Instant Reloading and Walking through Crates in a TTT Server

I’ve been attempting to make my own TTT server, however whenever I reload a weapon it will reload instantly. Also, I have the ability to walk through many different objects including crates. I know this is because CSS content isn’t installed correctly in the server. I’ve been able to download CSS using the SteamCMD. However, It still doesn’t fix the issue. I’ve tried putting the files in different directories that people have mentioned such as cstike in the orangebox folder and css in the orangebox directory, cstrike in the orangebox directory, and css in the orangebox directory. I have run out of ideas as to how to make Garry’s Mod have the CSS content. If anyone has any idea as to how I could make this work, I would be greatly appreciative.Thank you for taking the time to read this post.

are you using steamcmd for your gmod server?

In the same boat as the OP here (though it’s an existing server that was broken by our server host, and I used their control panel to reinstall CSS). I noticed that my server’s cstrike had the CSS content in .vpk form instead of being extracted. I never checked before, so I’m not sure if this is normal or if it is supposed to be in extracted form.

[editline]1st June 2013[/editline]

This is probably an awful idea but I downloaded all of the .vpks, extracted them and am uploading the content back to my server. It’s gonna be a while but I’ll post back if it works.

Space Core, I am using the normal hldsupdatetool for gmod because the steamcmd currently only supports gmod beta. So, it’s possible that once they move gmod over to steamcmd that it could start working again. ChromaX, let me know how that goes.

Put the cstrike folder into the orangebox folder. You’re getting these errors due to CSS not being mounted.

That’s where my cstrike folder already is and it’s still broken. Btw I’m 80% done uploading the unpacked vpks I found in the cstrike folder with 20 mins left, so we’ll see if thats what is causing the issue (at least for me).

[editline]2nd June 2013[/editline]

Ok, finally finished uploading the files. Weapons are still broken, but some CSS props that I could walk through before are now solid and fixed, though some are still broken. I didn’t upload everything I unpacked though, so I am trying again.

[editline]2nd June 2013[/editline]

That didn’t fix anything else. Oh well, sending a support ticket to the host so they can fix their shitty installer.

Ok, I restarted my server completely this time and now it looks like all of the CSS prop and weapon stuff is working again, so it was caused by the vpks. The hard way to fix this is to download all of the .vpk files from your cstrike folder (if you have a remote host), and run vpk.exe (I found it in \steamapps\common eam fortress 2\bin) on cstrike_pak_dir.vpk, and then upload the folders it extracts back to your server and restart the server. This is a shitty time and bandwidth consuming solution but it worked for me in the end.

@ChromaX The VPK is 654kb but it seems like there are a million files in it :open_mouth:

EDIT: It extracted 1.3 gigs from 1mb…im guessing all the other vpks got extracted too.

EDIT: I extracted the content, I made a symbolic link from the garrysmod/cstrike to CSS Dedicated Server/cstrike and I have content.txt.
Still no reload anims, props are still frozen. Meaning that CSS is still not mounted.

We have this issue too. Tried a lot of things, still haven’t managed to fix it. At first we thought it was our custom reloading script, but thank god it isn’t

Unfortunately, steampipe is causing many problems with CSS not being able to mount. Your client has the content installed and mounted, but the server doesn’t, so that’s why the weapons reload instantly.

Fix Method: Donwload old version of GCF content “counter-strike source shared (v131)”. Fill up Garrys Mod folder using CSS extracted folders from GCF content (Materials, Models). This method is temporary, we need to wait new garrys mod update, which will fix content mounting. Sorry for my bad english

Cheers for the tip it works nicely, aside from the sound problems it does indeed fix the problems.

Could someone post a link please? Id really like the GCF stuff, but no clue where to get it from… Thanks in advance, ExoHosting.

Sorry for the double post, but i´d really want to know how to get these files, to get it fixed. Hopefully someone can send me the link, or explain more detailed how to do it. Thanks in advance, ExoHosting.

Make sure when you either symlink or copy the cstrike folder into the server directory, that you update mount.cfg as well. The entry for cstrike should look like:


"cstrike" "cstrike"

I was reffering to this method, since the Mounting does not work properly yet.

symlink/copying not required ever since mount.cfg.