Insurgency: custom ACOG is white on servers

Howdy,
so here is the drill: I was going to port the BF3 ACOG into Insurgency(2), model is perfectly aligned for aiming and even the zoom feature works again (i’m replacing it with the 2xAimpoint).
My only problem is that whenever i join a server, the model turns white. It only happens to the custom parts, optic lenses still work because i keep the default ones. It’s not even a texture error because it’s not pink and it shows the texture perfectly fine when i create a local server.
I also tried different models and they all gave me the same error.

I work with blender and i’m at my wits and as to what causes this.
I created the carry handle for INS before with a custom model and it still works perfectly fine (btw, i checked, if those servers were sv_pure).

Does anybody have an idea/solution?
If you can help, please keep in mind that i’m dumb as f#@k with blender and learned alot just by trial-and-error.

[img_thumb]http://filesmelt.com/dl/2014-09-23_00003.jpg[/img_thumb][img_thumb]http://filesmelt.com/dl/2014-09-23_00004.jpg[/img_thumb][img_thumb]http://filesmelt.com/dl/2014-09-23_00005.jpg[/img_thumb]

God damn an ACOG would be nice as fuck.
Hopefully you get it fixed up, I’d get it straight away

sure, there isn’t some sort of texture witelisting going on in insurgency? And once it detects a custom texture, it makes it blank white to prevent cheating and the use of various tool textures.

I’m fairly certain it’s not just a whitelist thing for several reasons:

  1. it still shows the custom textures on my carry handle, which is also quite different than the default flip up sights.
  2. The error is the same with an acog, taken from a CSS/L4D2 model
  3. just for the sake of testing, i even deleted the vmt as if it cannot load a texture and it still showed all white instead of the usual purple/black.
    (4.) it worked 1 time online and i’m not sure what changed. Kept the same server, same method of compiling, etc (or at least i think i did.)

sooo … no one has an idea?
That’s too bad.

Nevermind, once again i figuredi it out myself on how to fix it. Texture is working on servers again.
Doin’ some testing.

If you could say how you fixed it, I’m sure anyone having similar issues would appreciate the insight.

My mistake was, that the material layer of the model was somehow messed up.
What i essantly did was:

i took the properly implemented material layer of the default magaim model, assigned it to the acog model and renamed it for my own purpose.

Now, i don’t know if you can call it an actual solution or just a work-around but hey, it works in the end and that’s all that matters, doesn’t it? ^^