Intense graphical glitches on some maps.

System specs:
-AMD Athlon 64 X2 dual core processor 5600+ 2.9 GHz
-Sapphire 100287VGAL Radeon HD 5670 graphics card
-RAM: 6 gigs
-Windows 7/64-bit operating system

Downloads:
-Kermites
-Various sweps/sents
-Small other things
-Nothing actually downloaded in the short time-frame.

Since I had my computer upgraded, (Last Friday) some maps randomly black screen, then have odd graphical glitches. So far the only one that actually does this constantly is City_8. Which is odd, first time since upgrade, it ran normally and everything was hunky-dory, but after i exited and went back in (without downloading anything) it started doing this. Other maps have done it, but after a quick restart they work fine. One thing though, I’ve found that L4D models tend to cause this sometimes on other maps.

I have not tried un-installing and I do not plan to.

The glitches: I’ve tried deleting and re-adding and it still does this.
http://filesmelt.com/dl/rp_city800013.jpg
http://filesmelt.com/dl/rp_city800023.jpg
http://filesmelt.com/dl/rp_city800031.jpg

The missing texture: I’ve tried deleting certain textures, but no dice. (Not really important, but any answers would help)
http://filesmelt.com/dl/cs_assault000320.jpg