Invalid game type 'garrysmod' sepecified.

Hello folks,

ive recently set up a linux based gmod server, and currently i am having issues regarding the starting up of the server.

Following the linux dedicated server guide here:

i have reached the part where it asks to start up the server, having done the steps before, and yet it says garrysmod is in incorrect game type.

is there something wrong with the binaries? :expressionless:

bump, same issue still.

Two things, the Linux binaries are currently out of date, we are waiting for update.

And you need to run the srcds_run that is inside the orangebox folder not the main srcds folder.

thankyou very much, that has worked for me :slight_smile:

cd’ing into the orange box directory and ./srcds_run’ing worked perfectly.

someone should edit the wiki page to fix that.

[editline]09:12AM[/editline]

welp, we’ve gone from the game mode issue to the “Invalid steam key size” issue.

windows servers have it sorted yet im yet to find one for linux.

anyone have any ideas?