Invisible Modfied m16

Hi,

So I recently reinstalled a gun on my server, a new model. I just edited weapon_ttt_m16 and redid the model, and sound. Then I went into the game and i download the .mdl, though when I pick it up its invisible.

When I extract the .gma and put all of teh files in my garrysmod folder, it shows fine. Any help? Yes I did do reload stop.
Click hereto view video since the video thing wont work ;-;

Are there any console errors when you hold the gun? Also, did you modify the view model (v_) and make sure to not change the name?

No console errors. I did check the name for v_ and w_

[editline]31st March 2015[/editline]


AddCSLuaFile()

SWEP.HoldType			= "ar2"

if CLIENT then
   SWEP.PrintName			= "M16"
   SWEP.Slot				= 2

   SWEP.Icon = "vgui/ttt/icon_m16"
   SWEP.IconLetter = "w"
end

SWEP.Base				= "weapon_tttbase"
SWEP.Spawnable = true

SWEP.Kind = WEAPON_HEAVY
SWEP.WeaponID = AMMO_M16

SWEP.Primary.Delay			= 0.1
SWEP.Primary.Recoil			= .6
SWEP.Primary.Automatic = true
SWEP.Primary.Ammo = "Pistol"
SWEP.Primary.Damage = 23
SWEP.Primary.Cone = .04
SWEP.Primary.ClipSize = 20
SWEP.Primary.ClipMax = 60
SWEP.Primary.DefaultClip = 20
SWEP.AutoSpawnable      = true
SWEP.AmmoEnt = "item_ammo_pistol_ttt"

SWEP.UseHands			= true
SWEP.ViewModelFlip		= true
SWEP.ViewModelFOV		= 75
SWEP.ViewModel        = "models/weapons/v_khr_m1a4.mdl"
SWEP.WorldModel       = "models/weapons/w_rif_m4a1.mdl"

SWEP.Primary.Sound      = Sound("Weapon_M1A4.Single")

SWEP.IronSightsPos = Vector(2.039, 0, 0.239)
SWEP.IronSightsAng = Vector(0, 0, 0)


function SWEP:SetZoom(state)
   if CLIENT then return end
   if not (IsValid(self.Owner) and self.Owner:IsPlayer()) then return end
   if state then
      self.Owner:SetFOV(35, 0.5)
   else
      self.Owner:SetFOV(0, 0.2)
   end
end

-- Add some zoom to ironsights for this gun
function SWEP:SecondaryAttack()
   if not self.IronSightsPos then return end
   if self:GetNextSecondaryFire() > CurTime() then return end

   local bIronsights = not self:GetIronsights()

   self:SetIronsights( bIronsights )

   if SERVER then
      self:SetZoom( bIronsights )
   end

   self:SetNextSecondaryFire( CurTime() + 0.3 )
end

function SWEP:PreDrop()
   self:SetZoom(false)
   self:SetIronsights(false)
   return self.BaseClass.PreDrop(self)
end

function SWEP:Reload()
    if (self:Clip1() == self.Primary.ClipSize or
        self.Owner:GetAmmoCount(self.Primary.Ammo) <= 0) then
       return
    end
    self:DefaultReload(ACT_VM_RELOAD)
    self:SetIronsights(false)
    self:SetZoom(false)
end

function SWEP:Holster()
   self:SetIronsights(false)
   self:SetZoom(false)
   return true
end


Try changing the model of the weapon and see if that does anything.