Invisible weapon issue

I’ve been making a model and I finally got it in the game ,but one issue its invisible. I think it may be a problem with the .VMT so here’s the code

“VertexLitGeneric”
{
“$baseTexture” “weapons/v_phystool/phystool_sheet”
“$bumpmap” “weapons/v_gravtool/gravtool_sheet_normal”
“$selfillum” “1”
“$envmap” “env_cubemap”
//"$envmaptint" “[.2 .2 .2]”
“$normalmapalphaenvmapmask” 1
}

Not entirely sure, but I think this is the wrong section to post this.

I’m sorry if this is the wrong section ,but I’m quite irritated by this problem.I would like someone to help me,so if you can please do.

BUMP

Check the compile code. Make sure the texture path is correct.

I did several times, and if it couldnt find it, it would be purple and black.

Still waiting for help, also my HLMV crashes on startup ,so I cant see if it works in there.

2 things:

  1. If HLMV is crashing on you, you have 2 options.
    -A) Verify the integrity of the tool cache (go to the Tools window, locate the Source SDK, right click, properties, Local Files tab, click the above mentioned)
    -B) Reinstall Steam (you can either do this before or after option A, but this is also a more extreme method if option A fails to work)

  2. Judging by what was listed for your .VMT files, shouldn’t it be something like:
    *“VertexLitGeneric”
    {
    "$baseTexture" “models/weapons/v_phystool/phystool_sheet”
    “$bumpmap” "models/weapons/v_gravtool/gravtool_sheet_normal"

    “$selfillum” “1”
    “$envmap” “env_cubemap”
    //"$envmaptint" “[.2 .2 .2]”
    “$normalmapalphaenvmapmask” 1
    } *

Give that a try if you haven’t yet, it might fix the problem with the textures. If not, then idk.

I’ll tell if it works :slight_smile:

-Snip-

Ok so I’m having a bitch of a time explaining this so here is the problem I have a skin for this http://www.garrysmod.org/downloads/?a=view&id=29051 ,and I changed the skin so It would fit the physgun, but the problem is I have to have this installed for the other one to work. It all works fine except the skin applies to both of them because they have the same material path, and when I recompile with the new material location its invisible. THERE I EXPLAINED IT AS WELL AS I CAN!

And Silence perfect :D. Not really I still need help

Still broken and no one is helping :slight_smile:

[editline]3rd December 2011[/editline]

Bump again

[editline]3rd December 2011[/editline]

I fixed it because this fine person! http://www.facepunch.com/threads/1112309