Is it expected to have "very" low FPSes when there is a lot of players ?

Hi,

Today I played with 60 players on gmod (on a dedicated server) and my FPS got very low.
The server CPU core usage was ~50% so I doubt the server was lagging, but I was having very low FPSes in game (In the 10-40 range) and I wonder if having low FPSes is expected when there is a lot of players, or if my client (or server) is misconfigured. Usually when I play I can keep more than 60fps, sometimes going in the 100ish with like 20-30 players. However when the server had 60 players my FPS were very low, staying below 60fps.

I have some screenshoots of net_graph 4 if that may help, but I don’t know how to interpret it. The gamemode is Fretta based if that matters and there is very few addons and all of them are very small things. (ULib, ULX, PointShop, A simple stamina system that I fixed, and antipropkill that I took from steam workshop).

http://puu.sh/qvghO/5a653cc651.jpg

(This is at the start of the round and before round starts everyone is dead so that’s why it’s so low at the start of it)

http://puu.sh/qvgjj/bdf28b9c43.jpg

I don’t have any custom autoexec file on my client nor server.
The only thing I did set on the server that may or may not matter is -tickrate 33. I didn’t set any other rates as I don’t know what they do and I don’t want to break something.
I don’t realy understand what that means, there is a number (in/out) that I think is related to network usage but what is it ? KiloBits per second ? (If it is then the thing going as big as 2000 might be an issue ? Even if my internet is very not likely to be the problem here). Also I’d think if the server was lagging we would see the players moving weirdly, doing some kind of small teleportations but they are moving smoothly, it’s just my client FPS that are very low.

So yeah is there something to do to make my FPSes higher when there is a lot of player on gmod or every people is getting low FPSes when playing on a server with 60 players and there is nothing we can do to make that better ?

Thanks for your answers.

When my graph starts to look like that there is usually an awful contraption which has been made. If you have wire it could be something E2 or something like a lift or a complex structure like a gambling machine or an ATM. Regrading your FPS, not much can be done about it, the best thing you can do is sift through your addon and get rid of things which are not used. Things like your weapon pack can contribute to FPS problems.

Your tickrate is good thought, if your looking for advice on your server.cfg ours looks like (for a 80 slot server, peaks at about 65ish players)



sv_minrate			1
sv_maxrate			0
sv_minupdaterate	        1
sv_maxupdaterate	34
sv_mincmdrate		1
sv_maxcmdrate		34


Your would probably look like



sv_minrate			1
sv_maxrate			0
sv_minupdaterate 	1
sv_maxupdaterate	34
sv_mincmdrate		1
sv_maxcmdrate		34


Hope this helps,
Bings :slight_smile: