Is there any way to get SuperDOF working?

Since garry apparently “fixed” SuperDOF, it’s been broken for me by crashing to my desktop as soon as I hit the Render button.

Apparently turning off multicore rendering would fix the “crash to desktop” problem, but it hasn’t helped me at all.

Is there anything else I can do to get it working?

Edit:
Specs
Processor: AMD Phenom II X3 @ 2.8GHz
Graphics Card: nVidia GeForce 9600 GT 1GB
OS: Windows 7 Professional 64 bit

Got motion blur on?

I do, is that causing an issue?

What’s so special about SuperDOF anyway?

On my PC it shows as the opposite of DOF. It focuses on something far away and unfocuses things that are near.

Like so:
[img_thumb]http://filesmelt.com/dl/gm_construct00022123456789101112131415161718192021.jpg[/img_thumb]
(I’m aware this isn’t very good, it’s just an example of SuperDOF.)

Slow/ unsupported processor? What graphic card do you have?

Ah yeah, forgot to put my specs in the OP

Processor: AMD Phenom II X3 @ 2.8GHz
Graphics Card: nVidia GeForce 9600 GT 1GB
OS: Windows 7 Professional 64 bit

[editline]2nd January 2011[/editline]

You have to click on the object/point you want to focus on :stuck_out_tongue:
If you click on Alyx then render, you’ll see that she’s in focus while Gman isn’t

Turn off multicore rendering.

If there is anything in the command line (start up options) try removing them and see if that helps

I usually have it windowed and noborder’d for development work, still get the same problem on my native fullscreen settings though

Sorry for the late reply.
Yeah quite a lot of people mentioned that motion blur tends to crash gmod together with SDOF, so try to disable it. As well as HDR as that tends to bugger up SDOF anyway all the time.

Gives far cleaner more controlled results than DOF, tends to help in a couple of extra stuff as well. That is if you don’t forget to press render.

Compare SDOF
http://dl.dropbox.com/u/6252145/gmod/sdof/gm_construct0035.jpg
no dof at all
http://dl.dropbox.com/u/6252145/gmod/sdof/gm_construct0036.jpg
(the camera was too far in this image for DOF to work :~ - but you can see the far cleaner results from sdof)

Ah. All makes sense now.