Is there anyway to still get bspsource 1.3.9?

Is there anyway to still get bspsource 1.3.9?

I’m using bspsource 1.3.21 and I’m trying to animate an hl2 SFM, but I can’t decompile the map, because bspsource 1.3.21 fucks something up and it says a solid is missing, then hammer crashes.

Ive heard that bspsource 1.3.9 handles this better, but I just cant find it anywhere at all…

If you have bspsource 1.3.9, Please give me the files for it!

The HL2 Map I’m talking about is d2_coast_11

I dont have 1.3.9 but i seem to have 1.3.6 saved up years ago.

The latest version is 1.3.23, might wanna try that first.

I tried to decompile the map with different bspsource version, and I didnt get any error.

I did with bspsource 1.3.21 and 1.3.12
the vmf size of the .12 was bigger than the .21 but there was difference in hammer
I also did with vmex, and it replaced all areaportal with tools/toolsblack and turned them back to World (i still included it in the archive)

Here is bspsource .12 version, I have it since few years:

And if you want a special version of bspsource that doesnt decompile but act like a ‘bsp extractor’ to easily extract packed content from a map and also have some informations like which models, textures, particles, sounds are used in the map.
Here:

Well that happened again…

[editline]18th September 2017[/editline]

Didn’t work, same error

the error must come from your hammer.
maybe verify the cache of your game.

also does this happen with other decompiled vmf ?

Yep, but I’ma try verifiying now

In case your hammer.exe is corrupted, delete it, and then verify the cache to download a new one.

That didn’t work

SFM .vmf format is maybe different.

In bspsource last tab (Other), set the vmf version to Source 2010 and later.

That sadly did not work

https://www.mediafire.com/file/116oaqe01e4bp1x/d2_coast_11.zip

Here, this one works perfectly.

This one actually worked!

My question now is, how did you make it work? What program did you use?

I got the original vmfs from someone a while ago. So this one is undecompiled.