Issue with L4D2 SDK

I’ve recently moved all my games from C: to X:(new partition) which is where all my games will be stored, anyway- when starting L4D2 tools to use hammer I keep getting these errors, any reasons why? Any help will be greatly appreciated :v:

It seems to still be checking in the C: drive, so it cannot find any of the files. Does anything open after that, or does it just close itself?

Nothing opens after that, just sits there.

refresh your sourcesdk content + reset (it’s an option in the list)
and that will reset everything.

Also keep in mind that you must run that game atleast once so it can actually generate the .txt file

I tried this today, and tried again- but this didn’t work either…

Any other ideas?

I had this issue after natively installing to the D:/ drive.

Just make the gameinfo.txt in the folder it’s looking for in the C:/ drive, and change the search paths to say something like:


		SearchPaths
		{
			Game				"D:\Steam\steamapps\common\left 4 dead 2\left4dead2"
			Game				"D:\Steam\steamapps\common\left 4 dead 2\hl2"
			Game				update
			Game				left4dead2_dlc1
			Game				|gameinfo_path|.
			Game				hl2
		}