Issues mounting TF2 and a few others on a server

So in my server I have mounted a few games like HL2 and CSS that work and i have TF2 and a few others mounted the same exact way, and they wont load. I have created a mountdepot.txt file in the cfg folder with an appropriate config. Note I’m on Linux if that changes anything. I have looked all over and have asked other server owners that have all this mounted successfully and they say they have no idea. I got all my game IDs from the Steam database and downloaded them through SteamCMD.

What makes you say “they won’t load”?

Well you cant spawn anything from the games, but you can with the ones that have successfully mounted. If you or someone is willing to help you can add me on steam.

Shows us your mountdepot.txt and the way you mounted those not working games?



"gamedepotsystem"
{
	"hl2"			"1"
	"cstrike"		"1"
	"csgo"			"1"
	"hl"			"1"
	"tf"			"1"
	"ep2"			"1"
	"episodic"		"1"
	"hl2mp"			"1"
	"portal"		"1"
}




"mountcfg"
{
	 "cstrike"		"~content/cs/cstrike"
	 "csgo"			"~/content/csgo/csgo"
	 "tf"			"~/content/tf/tf"
	 "hl2"			"~/content/hl2"
	 "hl2mp"		"~/content/hl2mp/hl2mp"
	 "ep2"			"~/content/ep2"
	 "episodic"		"~/content/episodeic/episodic"
	 "portal"		"~/content/portal/portal"
}


Here is both sorry about not being specfic on exactly which ones are not working but to my knowledge its portal and tf2 and csgo

And “~/content/tf/tf” exists? Show me its contents?

What’s inside the tf/ folder? What props are you trying to spawn?

Anything in tf2 wont spawn, and like i said i used steamcmd to download team fortress 2 the correct version which was 17 Gigabytes. I’ve read somewhere that portal was a different story and you couldnt enable this way.

Firstly, make sure you do have the folder ‘cstrike’ installed correctly. After that you want to go to the mount.cfg/txt to edit where you out that/them folders in, I’m certain it goes into the bin dir.

Make sure to remove the ‘//’ or the game will not read, it’ll just make it as a void comment.
This’ll be the same process for mounting anything else I.e (TF2/DOTA/PORTAL/)

Goodluck, hope this solves your issue

So i did what you said and changed all the file directorys to point to the bin of each, and HL2 Cstrike still work the others do not.


"mountcfg"
{
	 "cstrike"		"~/content/cs/bin"
	 "csgo"			"~/content/csgo/bin"
	 "tf"			"~/content/tf/bin"
	 "hl2mp"		"~/content/hl2mp/bin"
	 "episodic"		"~/content/episodeic/bin"
	 "portal"		"~/content/portal/bin"
}



Im still not able to get it to load, i tried uninstalling and reinstalling and nothing works

still need help if anyone can help me?