Issues with bloom, gets more intense looking down and looks weird

I got an issue with bloom, I’ve had this issue for a year or so. The bloom gets intense looking at the ground rather than say, the sky.

http://images.akamai.steamusercontent.com/ugc/396675411364060085/6DF4DB546D464BB0D1EF39B4D263C5021EE4B3D9/[/t]

here it is when Im just walking around, it looks ok

but it burns intensely if you look right at the floor

[t]http://images.akamai.steamusercontent.com/ugc/396675411364208775/1D3FE7761641A71EADDD80E8A1C1BF0ED1E6C0BA/[/t]

also the sun looks like a cheese wedge

[t]http://images.akamai.steamusercontent.com/ugc/396675411364209117/46B6D0744FEF914C2A579ED724BFBB6CDF68A2C9/[/t]

I don’t really care about bloom per say, I just wanted the map to have a neat sheen sort of

[t]http://images.akamai.steamusercontent.com/ugc/3316084480659600061/62548A78201B8843A1A8C192878441F9150CA007/[/t]

this was my first bloom addition from long ago but I copy pasted that from some mario map and wanted to edit it to look more normal, even though I really like the blue tint. I think I copy pasted the newest one from dustbowl or badwater.

But like I was saying, I don’t really NEED bloom for the visual, it’s negligible, doesn’t need to be noticeable but cool effects ingame like this:

[t]http://i.imgur.com/yZkgQmW.png

just don’t work without it. (it would be a dull, non shiny, dark orange instead)

Any advice on how to properly implement bloom? Is there a way to not actually have noticeable bloom but still get the HDR effects?

mat_bloom_scalefactor_scalar 0.3

explore other commands that show up when using mat_bloom too

ok the sun stopped looking stupid

http://images.akamai.steamusercontent.com/ugc/396675411364254741/19C6CD5C41B54AB43E97DF89B55B77BA545B1BBF/[/t]

but the bloom still shifts into a weird way looking up and down.

[t]http://images.akamai.steamusercontent.com/ugc/396675411364255075/4845AA3EC36F7DBAAB210798177BD487905543FE/[/t]
[t]http://images.akamai.steamusercontent.com/ugc/396675411364255342/FAAFD001FD7E755C2F3A48951A031B693A116102/

it’s more noticeable watching, so I’m uploading a fraps recording of it. It gets darker looking up, more intense/bright looking at the floor.

Also, once I figure out what commands, how would I go about implementing them into hammer? I’m working on this again because someone who used to play on the older version contacted me to host a new server with it.

The camera automatically adjusts its exposure rate based on the brightness of whatever you’re looking at. You can limit the exposure rate using the mat_autoexposure_min and mat_autoexposure_max commands. For reference: setting both to 1 is the equivalent of running the map in LDR mode (if I’m not mistaken).

In Hammer, you can place the env_tonemap_controller entity anywhere in your map. Give it a name and call the appropriate inputs using a logic_auto entity’s OnMapSpawn output. For example:


OnMapSpawn -> tonemap -> SetAutoExposureMin -> 0.5
OnMapSpawn -> tonemap -> SetAutoExposureMax -> 1.5
OnMapSpawn -> tonemap -> SetBloomScale -> 0.8