Issues with weapon type addons

I know i have them installed properly in the addons folder, i can go into single player or anothers server and use my sweps (assuming they are installed) how ever on my server, i cannot get them to spawn, i click it, sometimes i hear a sound like when you pick a weapon up, but i get nothing. i dont even get an error. i look in console and there is a message “giving alur <weapon_name_here>” so i know is sees them some how, but my player doe not get them, nor do any other players on my server. I am not hosting my own server i am renting, ive rented before and it all worked fine. If any one has any insight on this it would be very helpful.

and yes i did put the addons in the addons folder on the servers host, the buildable addons like phx work fine but its just the weapons that dont work.

Is this a listen or dedicated server, because I had the same problem with my dedicated and recently fixed it. If its a dedicated, do this.

Delete orangebox\bin from your Srcds directory. When that is done, update Garrysmod.


cd \srcds
hldsupdatetool -command update -game garrysmod -dir C:\srcds


Your sweps should then work.