I've spent 2 days trying to solve this with no luck. 3D skybox water uses in level cubemaps instead of its own.

First, a video of my problem: https://www.youtube.com/watch?v=4H6ND0J6Yyc

I have decompiled 6 different maps that have working skybox water reflections, and cannot figure out what I am doing differently. Even recompiling their maps makes it work, so it isn’t something with how I am compiling.

All the stuff I have been finding on google is about the water in level only reflecting skybox. I seem to have the opposite problem which no one has asked about.

I’ve tried with many different water, and even went as far as copying the entire skybox + in level water.lod.control into my map and replacing mine. Still the same issue. What the hell is going on here?

Couple of pics: https://imgur.com/a/SBrI8

First pic is rp_richland with water in a similar way to what I am trying to achieve.

Second pic is my map, using the copy and pasted water, water.lod.control, and cubemaps. My map is after running buildcubemaps

If I can’t get it to work I’ll probably just revert to a 2d skybox. Really frustrated with this as I have spent all of my free time for 2 days trying to figure out wtf is the problem.

Any help would be appreciated

Could we get a compile log, please?

My bad, meant to include it.

Here you are:

http://dl.brandonglatz.com/ph_iamalion-compile-log.txt

-fast vis usually causes this issue. Try compiling a full vvis, and see if it fixes the issue. You should also have a water_lod_control entity located somewhere in your map. Preferably next to your light_environment, env_fog_controller, etc.

Cordon off the map around everything and make sure you run the compile as normal. Water gets glitchy if you compile in fast.

I think you can make a face use a certain cubemap by selecting the cubemap, then under “brush faces” use the dropper tool and select the faces you want to make use that cubemap.

Yup, got a water_lod_control near a middle water feature. Trying a full compile…

[editline]18th November 2014[/editline]

No change, I’ll try a normal compile

[editline]18th November 2014[/editline]

Both of my bodies of water have their cubemaps assigned that way already

edit: Nope, same problem :frowning: I have reflections now, but its still the skybox (yay) and the in world geometry (boo). Uploading a video to show it

did you build cubemaps?

…derp 1 sec please

[editline]18th November 2014[/editline]

Still doing it

Also heres the full compile log: http://dl.brandonglatz.com/ph_iamalion-compile-log-full.txt

Do you have water on two levels in the same leaf? Worded differently here, do you have one water brush that’s higher than the other, and able to see them both? if you have water on multiple levels it can be a bit weird. (this is excluding the skybox.)

Nope, the small round pond is the only water in the level. The only other water is the one in the skybox.

[editline]18th November 2014[/editline]

Heres the video: https://www.youtube.com/watch?v=enP2m7j_SZU

Tried to make a stripped down version of the map real quick on my break to share with you, but something broke in it and I didn’t have time to troubleshoot

[editline]18th November 2014[/editline]

Alright, got a slimmed down one.

Here are 3 screenshots that show what is still happening: http://imgur.com/a/8gDXJ
Note how the sky reflection follows the crosshairs, and how the skybox water reflects the in world building

The included bsp was compiled as final and has had cubemaps built.

Here is my vmf:
http://dl.brandonglatz.com/ph_iamalion_empty.zip

Anyone had a chance to have a squiz at the vmf yet? I’m almost off of work and would really like to get this figured out… I can’t really continue on my map without it :<

Okay so I edited the empty version of the map some more to where it is literally two boxes. Problem still persisting.

New VMF with included compile log and bsp with cubemaps built: http://dl.brandonglatz.com/ph_iamalion_empty_2.zip
Youtube video showing the problem still happening in this map: https://www.youtube.com/watch?v=UmGANz3Uzek
Here is the gmod console output from building cubemaps:



] buildcubemaps 
bounce: 1/1 sample: 1/4
bounce: 1/1 sample: 2/4
bounce: 1/1 sample: 3/4
bounce: 1/1 sample: 4/4
Creating default cubemaps for env_cubemap using skybox militia_hdr...
Dropped iamalion from server (Disconnect by user.)
PREP OK


I noticed after uploading it that I did not have the skybox cubemap specifically tied to the skybox water. I tried that immediately and rebuilt cubemaps but had the exact same problem.

Try a non-HDR skybox.

All of the ones I found on the valve developer wiki say HDR, and I couldn’t find any on google that were non HDR. Do you know of any that arent HDR?

[editline]19th November 2014[/editline]

Just tried a few more things:

Thought maybe the skybox texture in the skybox needed to be 2D skybox. Did not fix anything
Read somewhere that there might be a displacement interfering with the water. Deleted all displacements and recompiled. Did not fix anything.
Deleted the water in the playable level because I read somewhere that there can only be 1 reflective water in a level. Did not fix anything, and produced this interesting bug. Reloading gmod fixed it, but still WTF: https://www.youtube.com/watch?v=bg8qtoXCC1s

If I dont figure this out in the next day or so I guess I’ll just give up on the 3d skybox idea and just go back to a 2D one

-snip: thought this was for CS:GO.

It could still help! I’ll take anything that might work!

Maybe try to put your 3d sky area above/below/to the side of the main map?

How it’s been: http://i.imgur.com/ugICWO6.png
What I Tried: http://i.imgur.com/he75wK7.png

Same problem.

3kilksphillip suggested removing the water in the level (which I did) or setting the water in the level to a cheap one. Both didn’t solve this.