jiggle bones

well i tried jiggle bones on a simple cylinder but
the problem is that jiggle bones dont go in the good direction
when i move it up and down jiggle bones flope left and right
when i move it forward and backward the bones spin on them self

here is the basic model
http://img4.hostingpics.net/thumbs/mini_842434jiggle.jpg

and here the qc


$modelname mandrac/mayhem/jiggle.mdl
$cdmaterials "mandrac/mayhem"
$surfaceprop "flesh"
$body studio "jiggle.smd"
$sequence idle "jiggle_idle.smd" fps 1

$collisionmodel "jiggle.smd"
{
$mass 10
}

$keyvalues
{
"prop_data"
    {
    "base" "Flesh.Small"
    }
}

$jigglebone "jiggle1"
{
    is_flexible
    {
        yaw_stiffness 50
        yaw_damping 5
        pitch_stiffness 50
        pitch_damping 5
        along_stiffness 100
        along_damping 100
        length 15
        tip_mass 0
        angle_constraint 30
    }
}

$jigglebone "jiggle2"
{
    is_flexible
    {
        yaw_stiffness 50
        yaw_damping 5
        pitch_stiffness 50
        pitch_damping 5
        along_stiffness 100
        along_damping 100
        length 15
        tip_mass 0
        angle_constraint 30
    }
}

$jigglebone "jiggle3"
{
    is_flexible
    {
        yaw_stiffness 50
        yaw_damping 5
        pitch_stiffness 50
        pitch_damping 5
        along_stiffness 100
        along_damping 100
        length 15
        tip_mass 0
        angle_constraint 30
    }
}

if somebody know how to fix she would be nice that he explains me
thanks

no sure what you want exactly but I like using this setting on most stuff

$jigglebone “hair” {
is_flexible {
yaw_stiffness 200
yaw_damping 6
pitch_stiffness 200
pitch_damping 8
tip_mass 5
length 30
angle_constraint 37
}
}

the problem is i can’t record a video for explain because when i start frap the jiggle bones stop to move

but i can do screen

fraps is weird, I tried recording a video of some cloth I made for udk one time and it looked like it disabled the cloth, or at least lowered its FPS. if your recording a video, maybe use a screen recorder instead

http://img4.hostingpics.net/thumbs/mini_965915gmconstruct0004.jpg
http://img4.hostingpics.net/thumbs/mini_934222gmconstruct0005.jpg
http://img4.hostingpics.net/thumbs/mini_645652gmconstruct0008.jpg

any idea?

You’ll have to fool around with the settings. There’s the X, Y and Z axis and it looks like you messed up on the one that makes it go forward.

These definitions might help.

My advice to you is to fiddle with the numbers as well as using negatives and look at some examples of other jigglebone lines here. Change a number, Ctrl + S, switch to model viewer, F5, see if there’s a difference.

i allready tried to “fool around with the settings”
this change movement speed,gravity effect, max angle etc… but this is not changing jiggle bones orientation

Jiggle bones are disabled when your FPS drops below 45

ah ok
so if i set frap to 50…
ok i will frap it

[editline]22nd April 2011[/editline]

video here

I believe joint orientation is a part of it

joint orientation?

Yeah, the actual angle of the joints in the reference.

hum excuse me but i really don’t understand what you mean by angle of the joints
maybe i missed something
you know i never used bones
can you explain me?

The bones in the model? jiggle1, jiggle2, and so forth? When you create them, they have an orientation. You might need to rotate them to get the orientation to match up with what you’re doing.

look at the first screen
they are aligned with the model

well

still need help

He is right, the bones doesn´t even have to be aligned with the model. Try rotating them 90 degress in a direction, and try them again. If not, try rotating them 90 degress in the same plane. Tell me what you got

I think he might have solved the problem by now.