Joining server crashes my gmod.

Whenever I try to join a server, my gmod gets to sending client info, and then sends me to desktop, This has been happening since the new update.

I have tried reinstalling, disabling all my addons.

Any help?

Make sure graphics drivers are up to date, try going into c:\windows:\system32 and delete awesomium.dll

Update : It works after i fresh install but only once.

It connects, when i close gmod or d/c from game, it starts crashing again.

[editline]26th April 2014[/editline]

http://dumps.metastruct.uk.to/dumper.py?dump=hl2_140419_crash_2014_4_26T20_49_12C0.mdmp

The crash dump

[editline]26th April 2014[/editline]

Are you sure deleting a system32 file would FIX it? I’m a bit new, but i know that system32 shouldn’t be touched.

awesomium.dll is just being used by Garry’s Mod

Issue. I do not have the awesomium.dll in the system32 folder…

Any help?..

4 weeks later… Still having this issue…

Does your steam crash? or is it only Garry’s mod

Only GMod.

I think after hours upon hours of search i fixed it:

Anyone else with this issue put -dxlevel 95 in your launch parametres to fix!