JSON In Garrymod by Default?

I know I have seen a JSON module floating around… is it in Garrysmod by default though?

If it is, is it just require(“json”) to use it?

No it is not in Garrysmod by default.

There IS the GLON module which is an implementation of JSON which is included with garry’s mod.

Ew GLON,

http://json.luaforge.net/#download

You can download the recent version of JSON for lua there. It works right, just follow the instructions below.

yeah pretty much what he said.

Ahh thanks. Works great find me. Thanks for your help too Nori :slight_smile:

so what JSON do anyway

Data compression/encryption.

Data serialisation.

Lets all be fancy with it.

JSON turns data into a human readable format that’s used to save and send data. Many common programs have parsers for it too, including web browsers.

What. That’s pretty much the opposite of what it does, since it’s meant to make data easy to read by humans.


Go Datastream Team!

-snip-

Wow, that’s what I just said, good job.

GLON won’t decode standard JSON. (At least not the JSON Twitter returns) I tried.


Go Datastream Team!

-snip-

Then why is he saying

?


Go Datastream Team!

-snip-

I lol’d you’ve got little room to talk. “LET ME SPOUT MOUNDS OF BULLSHIT THAT NO ONE UNDERSTANDS AND CRITICIZE THOSE THAT MAKE IT SIMPLISTIC AND EASY TO UNDERSTAND.”

[editline]02:42PM[/editline]

(picture not by Declan “DecoDaMan” White)

That’s actually pretty funny, that there.