Jump pack

So the jump pack in ttt doesnt work for certain players on my server. I set the gravity to 15 and it works for me and another guy but not for anyone else. Any1 know the problem?

Would be nice if you posted code.

ITEM.Name = ‘Jump Pack’
ITEM.Price = 10000
ITEM.Model = ‘models/xqm/jetengine.mdl’
ITEM.Bone = ‘ValveBiped.Bip01_Spine2’
ITEM.AllowedUserGroups = { “admin”, “superadmin”, “donor”, “donor mod” }
ITEM.SingleUse = false

function ITEM:OnEquip(ply, modifications)
ply:PS_AddClientsideModel(self.ID)
end

function ITEM:OnHolster(ply)
ply:PS_RemoveClientsideModel(self.ID)
end

function ITEM:ModifyClientsideModel(ply, model, pos, ang)
model:SetModelScale(0.5, 0)
pos = pos + (ang:Right() * 7) + (ang:Forward() * 6)

return model, pos, ang
end

function ITEM:Think(ply, modifications)
if ply:KeyDown(IN_JUMP) then
ply:SetVelocity(ply:GetUp() * 16)
end
end

Try



ITEM.Name = "Jump Pack"
ITEM.Price = 10000
ITEM.Model = "models/xqm/jetengine.mdl"
ITEM.Bone = "ValveBiped.Bip01_Spine2"
ITEM.AllowedUserGroups = { "admin", "superadmin", "donor", "donor mod" }

function ITEM:OnEquip(ply, modifications)
	ply:PS_AddClientsideModel(self.ID)
end

function ITEM:OnHolster(ply)
	ply:PS_RemoveClientsideModel(self.ID)
end

function ITEM:ModifyClientsideModel(ply, model, pos, ang)
	model:SetModelScale(0.5, 0)
	pos = pos + (ang:Right() * 7) + (ang:Forward() * 6)
	
	return model, pos, ang
end

function ITEM:Think(ply, modifications)
	if ply:KeyDown(IN_JUMP) then
		ply:SetVelocity(ply:GetUp() * 20)
	end
end


i kno ive tried raising the GetUp() but it only works for me

It does work. I’ve tried it myself. Do they all have it equipped?

yes they all do and it only works for me

That means your other players are using it wrong.

Tell them to HOLD SPACE DOWN

they do and it doesnt work for them. I really dont get why lol

Well sometimes for me it’ll not push you as high as it should, other times it will.
What I do know is if you are totally stripped of weapons it won’t work at all.

thats werd that it only works for certain people

make sure they hold space

[editline]3rd December 2013[/editline]

if it works for some it should work for all