Just another "exception_access_violation" help post.

I’ve made a model in maya. After exporting is with MESA (prall’s exporter gave me the same results), and attempting to compile it I get… exception_access_violation (assert 1) and I’m struggling to get it fixed.

Some info:
-The model’s qc:


$modelname "test2.mdl"



$scale 1
$surfaceprop "default"
$keyvalues { "prop_data" { "base" "Wooden.Large" } }
$body "Body" "test2"
$sequence idle "test2_idle" loop fps 1

$root "bone_main"

[NOTE] The cdmaterials is missing because it’s just a test model, so I didn’t mess around with the vmt’s yet.

-Used ConTEXT for sompiling and SFM’s studioMDL.
-Having HLMV on when compiling, didn’t do a thing.

-My mesh has:
-verts: 42k
-edges: 81k
-faces: 40k
-tris: 80k
-UV: 47k

-Maya 2013 64k (using 2012 equaled in the same result).

-Mesh is not a static prop (in case that’s actually important)

Hope anyone can help me…I really do.

That’s really really poly heavy. So that might be your issue.

Yeah, I don’t think I’ve ever compiled a 80k tri model before.

I also think you need $cdmaterials.

Does anybody know the limit’s for the source engine then?

Also, to test, I’ve made a model of two cubes with both having one joint attached.
I’ve exported and compiled the model (worked fine), than moved everything into sfm’s usermod and I get this:

http://imageshack.us/a/img21/6019/beztytuulpl.jpg

here is the qc:

Those problems are really getting annoying…

My best guess is that you need to designate a collision hull. Almost all instances I’ve encountered with the exception violation deal with improper hulls. If you don’t want to make a hull, try removing the keyvalues/prop_data line. I’d guess that one of these will fix it.

Of course, it may also be the high mesh density. Your model stats are very excessive for a game engine. I doubt I’ve ever compiled higher than 12k tris (though maybe more… but certainly never anything like 80k).

Yep, thanks. I’ll try to devide the entire model into elements, and than group them in sfm.
Got any idea about the problem in second image?

You’re exporting from Maya; add $upaxis Y

I’ve made the upaxis Y in maya settings in-before.
But I’ll give it a try, just in case.

[editline]3rd April 2013[/editline]

nope, no success here.
Got some more info, if this helps,. When I try to spawn the test model, in the model import window, when I click on the name of the model I can’t see anything in its preview window, not even the grid. Also, when I try to open it in sfm’s hlmv I get a “error loading model” box.

I think you need to get your model under 32k vertices

Separated one element from the model which had 8526 verts, 16k tris, 15k edges and 8204 faces and two joints applied…and got the same error (hlmv running), so it must be something else.

Oh, yea. What do you think about the second problem? The one with the test models not opening correctly in sfm?

remove the $root line

does it compile then give you the error or just give you the error and not compile at all. post compile log please

Same. Slowly running out of options here.
I got a plan B to export it from maya in some format supporting joints into Blender. Heard there shouldn’t be any problem with this software.
Max, could I contact you via private and try to somehow fix? Don’t wanna clutter the post too much.

[editline]3rd April 2013[/editline]

Don’t really know how to get it for you. But I can say that I get the error right after “SMD MODEL snare.smd”

Which version of StudioMDL are you using to compile, and into which engine version?
I very, very much doubt that your vert ri count is the problem here. I’ve compiled models that are well over 100k of either in terms of both base model and bodygroups.
If you’re using source2009, it would allow you to compile such a model without any problems, though deformation would likely be really, really strange.

As sentrygunman said, you should also post the entire compile log; you can get this by compiling with GUIStudioCompiler or Notepad ++, and it tends to give better details on what exactly is wrong.
Although if it’s occurring immediately after reading an SMD, that’s telling me there’s an error within the SMD. Usually that’s something caused by the exporter; almost every time someone has trouble compiling and has asked me to help, re-exporting has been the solution.

I’d go with trying the Blender export, Collada (.dae) is a fairly consistent format to use.

Really glad to hear poly count might not be the issue here. Aimed for the model to be as hq as possible.

I used the Sfm’s studiomdl (but using the ep1 one got me the same effect), and aimed for SFM.
As software I used maya 2013 64, and mesa exporter: (http://puppet-master.net/plugins/mesa-for-maya/

Also, there’s the compile log (if that’s actually it, from notepad++):

I can’t currently think of anything other than a broken SMD from export. I still think you should try importing the model into another program and exporting to SMD from there.

Yep, I’ll probably get on to it.
Maya has always had problems with exporting smd models. Too bad valve doesn’t publish all of their crap for maya…

What? They do, all their plugins are for Maya

Most don’t really work too good. Trust me I’ve tried.

[editline]5th April 2013[/editline]

Also, it tends to not work well with maya 64

You’re supposed to use 2012 32-bit