Just reporting a bug here...

There was an update while ago (i’m switched to experimental branch), and when I tried to run Rust after it, the menu background came up, but with no buttons or text.
When I then tried to run in once more, it was okay, but I couldn’t see any server, but that is possibly because the experimental server is down?
So… yeah, that’s pretty much all I wanted, thanks for having a look at this if you will and hope it helps :slight_smile:

I had the same problem for some minutes, I restarted rust-experimental half an hour later and I could join the server, the server gets wiped every now and then.

Seems a bit of luck is involved in getting a menu at the moment, and a bit more for the server to be listed.

They’ve been messing with the HTML UI for a while now, it’s probably related. If in doubt, it’s probably a good call to uninstall the game, delete the game’s root directory, and then reinstall through Steam. Just to make sure you aren’t left with any old versions of files after updates and things.