Just StudioCompiler...

Hello.
I installed the StudioCompiler and when I want to decompile a model, it crashes.
I refreshed the SSDK content etc. but it still doesn’t work.

I’m using Windows 7.

Edit the MDL in notepad, change:

“IDST0” to “IDST,”

Come on man, do some research, there’s tons of places telling you to do this for orangebox models.

Yea, but it’s already changed.

It worked on WinXP, so why it doesn’t work now?

BTW. I am using 64-Bit Windows 7.

Didn’t he break the decompiler when he removed Steam integration

The decompiler works fine as long as you uncheck steam file access.
What I don’t understand is why people still use studiocompiler instead of the respective working and correct tools
Namely mdldecompiler and studiomdl

Yeah I never understood the appeal of those tools, the ones provided in the SDK work just fine, and are literally drag-and-drop.

Also I don’t know why people keep insisting on Windows 7 64-bit being an issue, I have no problems with any SDK application, and that’s the OS I am running.

Fully agreed. I’ve used both vista x64 and win7 x64 without the slightest issues. The only problem I can think of is people having UAC on with all the tools being located in program files as those end up being protected by windows and sometimes conflicting with software that’s using bruteforcing to try and use the locations.

If you have UAC on, you shouldn’t be modding.

I happen to disagree. UAC is in effect a very bloody useful feature of the OS. Just far too intrusive in Vista.

In essence it’s akin to a superuser in nix systems.

I disagree, any half-decently made virus or malware will slip right past it. The only thing it prevents, is the user getting anything done without half a dozen warning messages popping up. I’ll admit my only experience with it was on Vista for about a day, but after switching to 7 I didn’t even check, I just flipped it off right away.

I can’t use studiomdl, because, when I’m running it, it rapidly closes.

Open a dos prompt and navigate to your bin folder and run it from there. Or make a bat file for your qc and end it with “pause”

For example,



studiomdl.exe model.qc
pause


Also you don’t just run studiomdl, you drag a qc file onto it, or run it through a parameter.

But how to decompile a model?

As far as i know, Valve never gave one out for public Dev use. The only Decompiler that was ever made for public use was cannon-fodder’s and its been bugged for a over a year.

Cannondfodder from what i know has stopped making fixes, So until someone who is good enough in that sort of programming language comes along and makes a new one, we’re stuck using the old one.

Mdldecompiler works fine, for the most part. You get some issues here and there, and facposing usually gets messed up a little, but it works.

In most cases, yes it does. But it has hard time loading up .mdl’s Made with the orangebox engine, which I honestly find a bit annoying. On of my computers at home I was able to decompile a Player model, though on my recently built one with newer hardware the mdlcompiler doesn’t even recognize it as a model.

No it doesn’t have any issues with orange box models. As long as you do a minor hex edit.
The only thing that it sometimes messes up on OB models is faceposing as far as I know. Though even that might be fixeable somehow.