Keep getting pink black texture.

Recently, I started modelling, so I made this simple wood thing with a tutorial.

Everything goes fine, until I am compiling the textures, but they seem to be placed on in the correct folders.

This is in my .QC:



$modelname	"woodthing/thing.mdl"
$body studio "./thing.smd"
$staticprop
$surfaceprop	"Wood_Solid"
$cdmaterials	"models/woodthing/thing"

$sequence idle	"thing_idle.smd" loop fps 15

$collisionmodel	"thing_phys.smd" {
$Mass 5
$concave }


And this is my vmt:



"VertexLitGeneric"
{
	"$basetexture" "models/woodthing"
	"model" 1
	"$envmapmode" 1		
}


There is one thing I noticed about the matrial compiling, it sends the output to a Half-life2/hl2/matrials/models\woodthing

See the / / and then a \

Anyone who can find the problem?
Google’d it also

Change the cdmaterials to models/woodthing

Specify the texture after woodthing in your vmt.


"VertexLitGeneric"
{
	"$basetexture" "models/woodthing/nameofvtf"
	"model" 1
	"$envmapmode" 1		
}


Your model is looking for the textures in a models/woodthing/thing folder, when your textures actually went to models/woodthing.
The initial directories have to match, you specify which texture in the vmt after the initial directory.

I edited some lines, and now it works!

Thanks very much!!

Sorry for the double post,
After placing it in Hammer, I noticed it was very small, I forgot to scale it. So I recompiled both texture as .QC with a $scale 40 added, but now the model’s dimensions seem good, but the texture is still very small.

Does this has something to do with the .vmt?

Do you mean it looks low res? or that the texture doesn’t fit the model?

The texture doesn’t fit the model

Somethings up with your UV then

It fits good in XSI, but in hammer the model is invisible but at the bottom, at the origin you see a very small model of the prop textured.

I hope this will make some things more clear.

I made a screen of what happens in Hammer so it wil be understandable :v:

If you look very close, you see at the origin of the model, the original model, while the hitbox is normal size.

Also, sorry for the double post, but else the topic will disappear in the black hole of topics.