Keyboard mappings erased after trying Experimental.

After trying the Experimental branch yesterday when I returned to the normal game my keyboard mappings had been erased. I had to fill them in.
I still can’t aim. When I press the right mouse button the guns don’t zoom and center.
what do I need to fix the aim.

Crossing my fingers and saying under my breath

  • Please don’t say reinstall Rust. *
  • Please don’t say reinstall Rust. *
  • Please don’t say reinstall Rust. *

I had this same issue.

All I had to do was remap them and it saved.
Also, your zoom in is called [EDIT:AltFire] under the key bind area, just set it to Right Mouse.

The same thing happened to me. I had to look up the default keybindings to fix it. Kind of an annoying bug but you know it is alpha.

Thank you. I did try setting AltFire to right mouse but kept changing back to left mouse.
I’ll try again when I get home.

Go into your Rust folder and delete your config files. Rust will remake them when you launch the game, and voila (a lot easier than assigning manually). Did this the other day and worked fine for me.

Steam\steamapps\common\rust\cfg
delete all except favourites.cfg

Try exiting and re-entering the menu. That worked for me.