Kicked by EAC on my own server.

So I updated my server, joined, after a few minuttes:



[EAC] Kicking 76561197973863337 (disconnected)
 
(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)

sendjes has left


Any thoughts?

Opting for Experimental, game version is 1291, opting out of beta, game version is 1267, but the server is 1291, so you can’t join with 1267, 1291 still kicks eventhoug the game version matches.

Did the server launch option change?

EDITShould have edited my previous post instead of making a new one, my bad.

EDIT Edited installer from:



steamcmd /wait +login anonymous +force_install_dir ../ +app_update 258550 -beta experimental validate +quit


to



steamcmd /wait +login anonymous +force_install_dir ../ +app_update 258550 validate +quit


Which sorted it, and everything is working just fine now.

Did you delete the directory before running the command?

Before I did the Download/Install, I deleted everything except:



D:\Games\_Server\Rust\Release\server
D:\Games\_Server\Rust\SteamCMD\steamcmd.exe


Are those install paths custom?

I am just using the default path under steamcmd\common\steamapps\rust dedicated\release

Yep, I use a dedicated folder for my game servers.

Steam\SteamApps\common\Rust\EasyAntiCheat

reinstall the EasyAntiCheat with admin rights on your client pc
i have the same issue 2 weeks befor… that works for me :slight_smile:

You’re missing the point, but nevermind.

EDIT But I’m someone out there would benefit from what you describe.

Huh strange. Every time my buddy tries to join he gets rejected due to an incompatible version even after I wiped my entire directory and re-pulled the server files. He can connect to other servers without an issue.

Server version is 1294

[editline]2nd October 2014[/editline]

This is my batch file: RustDedicated.exe -batchmode +server.hostname "Noxis Boston 10/2 Seed 714238 " +server.port 28015 +server.identity “Noxis” +server.seed 714238 +server.maxplayers 100 server.secure true

Has the user checked his 'beta" opt in status in steam for Rust?
lately it seems you have to “opt” out or in to get some servers to connect.

and even then you have to double check the downloads to make sure the rust update isn’t just sitting waiting for you to tell it to update. weird.

I am so confused right now. After removing the beta and experimental arguments for Steam CMD the normal opted out client becomes incompatible.

Regular Client Version 1267
Beta Client Version 1294
Server Version 1297

How do I get my server to be compatible with the opted out version?

lol yeah. its crazy.

I did change my server run directory from Debug to Release in the command line.
might see if it helps.

but I think that last update has a lot of users being kicked by EAC for version.

I’m just spitballin’ here, could it have something to do with Exp being the default now, and the server and client updates are a bit delayed?

yes I think there is a issue of some sorts. there is a Release version of experimental and the Debug version of experimental. I wonder if something is getting messed up with the updates between the two.

Maybe but people are playing fine while opted out. They cannot join my server though due to being incompatible…did the others servers just not update?

i had people playing fine on mine until I manually ran the update 2 hours ago. and
now its EAC issues for everyone connecting. Must be the update. and apparently there has not been a client update to match it yet.

Ok yea same for me, people are not getting authed with EAC. The other servers probably just haven’t updated.

for now disable EAC via server command

server.secure false

if you want to use newest server files

correct Kulan, that works perfect to test out the newest server build :slight_smile:

Woooo hoo hooo, something is weird for me… i ask

I see in this tread Sendjes have server version 1291, 20 hours ago its ok
Warm ask his Server version is 1294, 18 hours ago its ok
And why i updated yesterday mean less of 20 hour ago and my Server version is alway 1135? what i lost? i had i have been follow this tread and delete all release folder :confused:
Are you launching by debug folder or something like that guys?
By the way do you know someone Garry talk about debug version is 32bits compiled in the wiki tread, and i cannot run it on win32 OS debug version it return bad file executable 32 bits blabla that mean its not a 32 bits compiled, have you try 32Bits OSes?

Oppps i had i see my version with the “status” command in game…

Maybe i’m stupid i think i just understand :confused:
http://forum.facepunch.com/showthread.php?t=1428227 many version experimental

Regard Bil