L4D model completely invisible?

ZS_Plaza has one obstacle left before being released. I’m trying to add a L4D model to it (store shelf), but the model is completely invisible. I followed the guide (extract from the vpks, copy the mdl, vtx, phy, vvd, then make 3 copies of the vtx, rename them to *.dx80.vtx, *.dx90.vtx, *.sw.vtx, then put them in the models folder) but it’s not working. When I try to place the model, I can move a box with its dimensions, but cannot see it at all. I can see the wireframe if I check some of the properties from the model selection window.

Edit: THIS HAPPENS IN HAMMER NOT IN GAME.

Any help would be greatly appreciated.

have you tried setting it to all three,

prop_dynamic
prop_static
prop_physics
?

Do that and then come back with answers

[editline]lol[/editline]
Oh, my bad, didn’t see the BOLD text.

:downs:

are you compiling in the ep1 engine?

Yes. CSS Config.

-whoop i didnt see the bold there but l4d models tend to be screwed up when viewed in the ep1 engine’s hammer-

Well great, if I compile with the EP2 engine the CSS materials aren’t gonna show up.

edit: okay then.

Simple fix: Use GCFScape to put things in Ep2’s directory.

This is one gigantic pain in the ass for one shelf model.

Fuck it, I’ll think of something else.

Check the VMT, shader and for extra materials commands.