Lag in rust because of a bug - please help

So, there’s a bug for me and nobody else seems to have this.
The only graphical setting I can use is fantastic, when I change it to fast and launch the game and quit again, it’s gone back on fantastic.
In a previus post someone told me that when i exited the game it crashes somehow and does not save the settings, he said that I am playing on fast, I just have to manually set it back to fast every time i launch the game. But!—>

—> I’ve tried leaving it on fantastic and i got around 30 - 40 fps.
When I set it to fast i still have around 30 - 40 fps.

I’ve tried reinstalling the game completely and reinstalling steam, nothing worked.

Please help.
Thank you.

Set the graphics settings in-game using the slider on the options screen. The launcher settings don’t seem to stick.

There’s really not that much FPS improvement with the graphics slider, You can notice the effect by looking at your torch at night, You’ll see more details on it on fantastic, less on fast

So the render slider in game, is basicly the same as adjusting the settings in the menu before you press play?