Launch Error

keep getting this on attempt to launch
rust launcher error: network error - could not connect to the easyanticheat network!
tried:
-reinstalling
-deleting all the registry files
-running as administrator and or in compatability mode
-manually installing easyanticheat from rust folder
-disabling firewall
-i can run rust from the folder directly but it seems to run the old experimental before it is live? there is no servers available.

Hi,

Something is preventing EAC from connecting to the servers. EAC uses port 27015 TCP, so please check from your firewall/router settings that this port is opened for connections.

We have noticed that some ISPs are doing network traffic shaping and blocking EAC downloads during daytime and allowing at evening/night when there’s less traffic, so due to this we are currently working on switching to HTTP CDN. This will happen within few weeks and hopefully will fix the issue for you as well, in case firewall/router won’t help.

Well I completely reinstalled the game today and tried again with both computer and router firewalls off, same thing occurred. Bit frustrating but im keen to see the game when I get the chance.

Hi,

This can be a firewall issue. If you have disabled your firewall and the problem still exists the problem might be also due to our network protocol being filtered and/or shaped by your ISP. This is a problem for some players and due to this we have now modified our backend to feed the anticheat module by HTTP protocol.

As its still under testing, could you try if it fixes the issue for you? To test, download and replace your existing EasyAntiCheat .DLL files in Steam\SteamApps\Common\Rust\EasyAntiCheat\ with these files: http://sandra.easyanticheat.net/test/ and then start the game from Steam again.

If it works we will update it to everyone.

Hi replaced both those files, twice verified game cache twice, had both router firewall and computer firewall off, Avast turned off, still nothing… Its been like two weeks now, My ISP is Telstra in Australia, why is Australia’s main ISP filtering and shaping your network protocol and why it still continuing to do so? Also from what little info i can gather from the internet this doesn’t seem to be so widespread that it is happening to everyone using Telstra. What else can I try? I might try re install it all again now…

Hi,

We have switched the network protocol to standard HTTP with port 80 (when using the new files located at http://sandra.easyanticheat.net/test/ )

If you can browse internet then the port 80 is open, but there could still be some firewall blocking EAC connection to our backend. Unfortunately from our end we cannot do much more for this issue, so I would suggest trying to contact your ISP if you are sure that you dont have any firewall and/or antivirus software which could be blocking EAC connection.

Ive tried everything, including uninstalling my anti-virus. I guess I might get around to calling my ISP, though that is going to most likely be a massive pain the ass to get talking to who I need to talk to, and get them understanding what I need done. Anyway thanks for your responses.

Hi,

Some technical info if you are going to contat your ISP:

EAC connects to DNS download.easyanticheat.net to port 80 TCP when using the new files from http://sandra.easyanticheat.net/test/

Without the new files it uses the old protocol and port 27015 TCP. Connections for players located at Australia go to servers located at United States East Coast.

Btw. can you open http://download.easyanticheat.net/ in your browser? You should get “400 Bad Request” if it works. If you can open that address then the connection works but for some reason it still fails to download the module from our servers.

Im wondering that could your ISP have some kind of hardware antivirus firewall that is disconnecting the download from our backend? It would be highly unlikely, but technically not impossible. Usually those kind of hardware devices are only used in closed environments like work places or universities etc. that want to filter out possible viruses/trojans at the edge of the network.

So basically:

BUT

For some unknown reason something is preventing you to download the client module from the server. This is unfortunately something that we cannot investigate from our end :confused:

Yeah I get the “400 bad request”. Basically my ISP installed new Fibre Optic this year to homes around my area, previously Australia used copper, it seems they installed hardware that belongs to them within the house also, like a box where the connection first comes in before it goes to the router, along with providing the router. So what you say is very possible. There was no problems playing legacy Rust and I used to be able to log onto experimental before it became live also.

Its probably a fiber converter that converts the fibre optic to normal ethernet, shouldn’t be any firewall in that. Strange problem…

Could you do one test for me? On Windows command prompt type “nslookup download.easyanticheat.net” (without the quotes) and tell me which IP-addresses does it resolv.

when I do it, it says server: unknown
address:10.0.0.138 (which is just router address)
then
*** UnKnown can’t find download.easyanticheat.net: No response from server.
This is with Windows and Router firewalls off.

Thats super weird, since that means that your DNS resolver cant resolve address download.easyanticheat.net which of course is the reason why the client is not working for you. For me I get a result like this:

http://puu.sh/cdpoK/853980f93c.png

BUT:

At the same time when you open your web browser the http://download.easyanticheat.net/ works which means that the name servers should work just fine.

You could try switching to Google’s DNS-servers which are 8.8.8.8 and 8.8.4.4 and see if that fixes the problem for you?

You can switch them from Windows control panel in Network connections. Like this:

http://puu.sh/cdpCd/5824f2cc65.png

Cheers I will try this now.

[editline]16th October 2014[/editline]

Same again, except showing address as 8.8.8.8, and yea both times showing Server above address as UnKnown
C:\Users\Soy
slookup downloadeasyanticheat.net
Server: UnKnown
Address:8.8.8.8
*** UnKnown can’t find download.easyanticheat.net: No response from server
and yea last time other address

There has to be something from in your operating system, router and/or firewall. nslookup should always return you the IP-address of the server that you try to resolv with the nslookup command.

What if you do “nslookup google.com”?

It should return something like this:

http://puu.sh/cdPxm/a929df6652.png

That is from my computer and the 192.168.0.1 is the IP-address of my router which act as a name resolver also. It returns the IP-addresses of the servers behind google.com.

Hey, the same thing again, on both google dns address or my routers one, with windows firewall and router firewall still turned off. Shouldn’t my server also be saying something instead of UnKnown, like how yours says Erakko.Ian

Basically the problem is that your computer is not resolving DNS-addresses correctly and it does not resolve download.easyanticheat.net. I cannot say why this is happening, but it’ not something that we can fix from our end, unfortunately.

Ok well I really appreciate your help. I dunno what to do either I guess google is the first place to start I suppose. Thanks for your time, I learnt a bit out of it.

Hi,

No problem. I hope that you get it working.

i had this problem go into

paste the file into here and run it

D:\Program Files (x86)\Steam\SteamApps\common\Rust\EasyAntiCheat

Link Removed

^ The uploaded file is NOT made or signed by EasyAntiCheat, please do not open it, we don’t know what it does.