Launch Issues

About a year ago i downloaded and installed Garry’s mod from Steam, updated it and attempted to launch the game. The game would sit on the initial splash page (the screenshot of the game with “Loading” down the bottom right. At this point the game would become unresponsive yet programs running in the background remained responsive (teamspeak etc) and i was unable to minimize or close the game in any way. Recently i downloaded the game again, since the last time i tried to install and play the game i have upgraded my PC entirely/reformatted multiple times and i encountered the same problem, i get to what should be the menu and it just sits on loading until i reboot my computer. Any help would be appreciated.

Also worth noting is a friend of mine is having the exact same issue.

My specs are :

AMD Phenom II 3.2ghz Quad
4 gig 1333hz DDR3 ram
NVIDIA GeForce GT 240
windows XP 64bit professional

Have you tried verifying the cache?

I have tried verifying the cache, it downloaded some files (missing files i guess) but it still wouldn’t work.