Leak Heli rotor animation

i was wondering of someone could animate the rotors on the leak heli so i could use it on a addon im working on. Also if you know how to could someone cut the heli into three parts for gibs when it blows up preferably cockpit, body, and tail pieces.

link to model: http://www.garrysmod.org/downloads/?a=view&id=2700

Here you go!

That includes the reworked helicopter model with the included ‘movement’ animation and 3 pieces that you can use as gibs.

thanks so much BabyFawnLegs for making the gibs and animation you should see this in the releases soon.

http://www.kidney-friends.net/images/smilies/hi5.gif

after testing it i have a question.
im using

function ENT:SetAutomaticFrameAdvance( bUsingAnim )
self.AutomaticFrameAdvance = bUsingAnim
end

to get the animation to play and it isn’t playing the animation. it might have something to do with what you named it but im not sure because i dont have anything to view the animation with. any ideas?

The animation is called ‘movement’. You can view a model’s animation in Model Viewer, one of the tools included with the SDK.

i have sdk but im not sure how to get custom models in to it, ive tried before but im not sure what directory to put them in.

You can just add the models to a game like Episode 2 the same way you’d add them to Garry’s Mod, then select Episode 2 from the drop-down in the SDK launcher and the Model Viewer will look in the Episode 2 directory for local content. Alternatively, you could add a configuration for Garry’s Mod to the SDK. If you want me to help you with that, I can.

ok so i did that and when i loaded the model it said error loading model i hit ok and the model showed up but it had no sequences.

EDIT: that was in hl2 when i put it in ep2s directory i get the sequences and no error nice anim btw.

That’s weird. It works fine for me. Did you, by any chance, move the model to another folder? This problem commonly occurs when a model is moved to a folder other than the one it was compiled into.

well its fine now but i still have to figure out how to get it to play the sequence. im trying this now

local sequence = self:LookupSequence(“movement”)
self:SetSequence(sequence)

ENT.AutomaticFrameAdvance = true

ENT.Spawnable = false
ENT.AdminSpawnable = false

function ENT:SetAutomaticFrameAdvance( bUsingAnim )
self.AutomaticFrameAdvance = bUsingAnim
end

I don’t know enough about LUA to help you with that but if you want me to recompile the model with the rotation animation as the idle animation, I can do that.

Could you please recompile the movement as the idle animation. Because i cant get it to work with lua. thanks.

Done!

It works beautifully thank you so much. heres a video of it: http://www.youtube.com/watch?v=HMu_NM4MVIQ

Looking good! =D

You guys forgot those helicopters have contra-rotating blades, which is why they have no tail rotor.

Still really awesome, though.

heres the release:
http://www.facepunch.com/threads/1057057-Leak-Heli-Gibs-SNPC?p=27880261#post27880261