left 4 dead 1 and 2 model problems

ok so my problem is that the left 4 dead 1 and 2 survivors have checard eyes…i downloaded l4d models b4 and they were fine but this time i downloaded the l4d2 models and this happens (infecter are just there no problem with the special infected)

http://screenshot.xfire.com/screenshot/natural/35ab49dce729552011ee89b6448f4b08d260950d.png

and with l4d 1 the normal infected lag the crap out of the game(special are fine) what is rong and how can i fix this?

(also yes youve probly seen this screen shot b4 i put this picture in a nother thread because me and some one else was having this problem but im making a thread for this problem because the other thread was 4 people who wanted the models)

well uh checkered means you are missing the textures so it is probably that the eyes in this are l4d2 models and since it isn’t out yet (except for the trial version) you don’t have it maybe man i don’t know enough to really understand the situation

Why would you reply if you didn’t know what was wrong?

Yeah, you’re missing the eye textures. Try unmounting/mounting or reinstalling Gmod or L4D.

Its not missing textures unless you installed it wrong and you can’t mount L4D

Read troubleshooting here- http://www.facepunch.com/showpost.php?p=14993311&postcount=1

He didn’t mount the game. Its not possible since L4D’s engine isn’t compatible with Gmod due to some fancy gismo stuff.

You are using dx8.

i has same problem

It means your hardware/software isn’t up to par. (AKA update your comp)