Lighting artifacts on changed materials

I’ve been working on a few sets for a future video, but I can’t seem to get by these lighting issues when setting up lamps. It only happens on props that I have applied different materials on. I was hoping there would be a way to fix this without upping the r_projectedtexture_filter value, causing the entire scene to suffer.

Here’s what it looks like…

Anyone have any ideas?
I’ve tried a whole mess of lighting commands which don’t seem to do much, and while the flahslight does provide much better results, I would need more than one. I’m unsure if that would be possible, but any solution would be great.

Post specs.

Should be well with that, even with incredibly high shadow res (Not the problem, happens even with default).

Currently running.
Windows 7 64-bit
Intel Core i7 960 @ 3.20 GHz
ATi HD 5970
6 gigs RAM

No overclocking on anything.

I do wonder if skinning the default material would prove better results, but that shall be something to test later in the day.

It would prove the same result since you’re just masking not changing it. Seems odd (I was expecting the malicious GMA to be present) that GMod is doing that.
Only 2 things I can suggest is to update drivers or delete whatever that addon is and re-download it.

I would hope an addon isn’t confliction, as I am running next to bare when it comes to that. This seems to be a problem I have had before, and was hoping I wasn’t the only one.

I’ll try to tinker around with it more for the next few days, and really hope I don’t have to change so much with my original scene idea. Though it would be a reason to push me to learn hammer.

I’ll try and keep you updated.

Edit: Nothing seems to be working, not sure what can be done.

I apologize for the bump, but I honestly can not seem to overcome this problem. Installing a light on my Egg Mobile is becoming especially a paint due to this issue.
After countless reinstalls and ultimate cleanouts, I don’t understand what could be causing this. It might be a command setting being saved by the cloud and whatnot, but I have no idea how I would keep that from being brought over from the last install. Disabling the cloud support proved no success.

It seems to happen based on distance and rotation of the lamp. It also seems to happen on props regardless of material at said distance variations. Does anyone else have any idea what might be going on?

Additional shot of flashlight being used on a prop.


You are not the only one with this problem. Yesterday I’ve meet with this problem too. I don’t know why…I’m guessing there was a minor update, what affected the game badly, but maybe not…don’t know, I’m not a programmer. I’ve done everything, reinstalled gmod (n+1)^m times, reinstalled my video driver…etc. Nothnig used.
On the other hand, 3/3 pc produced this, so it must be something with te game. Only what I could do, is to change the blur amount of the lamp, but it is still there.