Lighting changes when walking through hint brushes

Problem still not fixed!

Aaahh! A problem that I greatly need help with!
For some reason whenever I’m in game and walk through a doorway that has a hint face over it, the lighting changes slightly. This also happens if I look up at the sky. I sometimes even get a slight flash of light across my screen.

I’ve searched around for this problem quickly, but no luck. Need urgent help if ANYONE knows a solution!
Could it be to do with func_viscluster or maybe the HDR? You guys will get a new map of mine in a few days if this can be fixed now!

http://img687.imageshack.us/img687/6204/gmfalcon40006.jpg

Lighting suddenly clicks brighter, not slowly as HDR does.

http://img201.imageshack.us/img201/9322/gmfalcon40007.jpg

Also… is there a way to create a displacement over a displacement without generating shadows. Such as a sandy and rocky hill over a sandy and grassy plain?
You can see an example of this in the first photo.

It doesn’t seem to do it when HDR is turned off, so why is HDR causing problems with my hint brushes?
I need both of them. What can I do?

Are you using color correction at all?

[editline]7th February 2011[/editline]

Also try removing the hint

I am using colour correction, but turning it off has no effect.

What do you mean THE hint? There are far more than just one.
I would have to remove every single one for it to have an effect, like I wrote, the light changes when passing through EVERY hint brush.

Didn’t see this post, if hdr is causing it I don’t have any idea what would cause that, try updating your video drivers

[editline]7th February 2011[/editline]

Check to see if you accidentally added 2 env_tonemaps. Just a thought.

My map doesn’t have any env_tonemap’s.

I tried removing all the hint brushes and yet the light still buggers up when looking around or walking through doorways.

Then where are you getting your hdr from?

[editline]7th February 2011[/editline]

If it’s stock you’re using, try using a tonemap controller

[editline]7th February 2011[/editline]

Env_tonemap_controller is the actual name iirc

All you need for HDR is a light_environment and the HDR option checked on compiling.

I’ve used tonemaps before but I will add one and mess around with the HDR a bit, see what happens, I doubt anything as the problem is something to do with the visleafs.

Yea try not using stock, and have the controller set to max 2.0 and min .8

As I guessed, it didn’t help at all.
So many months put into a level that I can’t even release.

Are you using a HDR skybox?

I am indeed. Not 3D yet though.

Have you tried copying everything to a new .vmf?

Maybe a compile log would help.

I’m just going to make it non-HDR. It’s a shame, but I don’t think I can fix it.

Post the compile log.

I’ve been compiling it without HDR, so you wouldn’t notice the problem in the current logs.
I will re-compile it tomorrow with HDR and post that log.