Lighting/Shadows - Need help

I’ve been having a problem for the past few hours where I can’t get shadows to properly display. I want them to be smooth, without being pitch black. Please assist!

though it shouldn’t be caused by brushes necessarily, you should know that recently with the wildfire update there was a large change to the lighting system and how it works in csgo.

check out this link here to read all of them http://blog.counter-strike.net/workshop/maps.php#new_features

but the most important that you need is go enable the advanced compile options (just click advanced when you open the compile menu) then in the light_exe row make sure you add the parameter
-StaticPropLighting and -StaticPropLightingScale # (The number can range from 0.25 to 16, with 16 being lighting of a full final compile and 0.25 being more like when vrad is set to fast).

try this out and see if it helps you out, otherwise shoot me your compile log

You have to compile with HDR.

Thank you both for the responses, I’ll try those and edit this post with my findings.

EDIT: All I had to do was set it to expert mode. Thanks!

Compile with HDR lighting. CS:GO does NOT support LDR (normal lighting)

Thanks!