Lightwarptexture for model doesn't work

Ok, so I made a VMT that has a $Lightwarptexture and the texture only shows up as the pink and black checkers.
I made a VMT (I copied it below).

The texture is Vertexlitgeneric, and is applied to a small spherical model so I could see if the Lightwarptexture works.
I made all the vtfs; a white texture for the base, a light blue bump map for the lightwarptexture, and a 16x512 lightwarptexture that goes from black to dark blue.

Here’s the VMT:



"VertexlitGeneric"
{
	"$basetexture" "models/ball/skywhite"
	"$surfaceprop" "default"
	"$bumpmap" "models/ball/sbbm"
	"$lightwarptexture" "models/ball/sblwt"
	"$nocull" "1"
}


Here’s the QC for the model:



$modelname		"ball.mdl"
$cdmaterials		"models\ball\"
$surfaceprop	default
$body		ball	"ball_ref.smd"
$sequence	idle	"ball_idle.smd" loop fps 15
$collisionmodel		"ball_phys.smd" 
{
	$mass 10
}


Does anyone know why it won’t work? And help would be greatly appreciated! = D

Lightwarp only applies to phong-enabled textures. Turn phong on and you should be set.

Not mentioned on valve wiki: http://developer.valvesoftware.com/wiki/$lightwarptexture

I’m not sure why you are using nocull, or is it rly needed that your texture appear on the reverse side of the surface ? If not don’t use this and just remove it out of your vmt.

Though make sure the files are correctly named in the right folders, and also try to experiment with phognwarps and light warp, example of a prop/weapon vmt:


"vertexlitgeneric"
{
	"$basetexture" "Boba_Fett/portable_dhd/buttons"
	"$bumpmap"    "Boba_Fett/portable_dhd/buttons_normal"
	"$normalmapalphaenvmapmask" 1
	"$surfaceprop" "plastic"
	"$envmap" "env_cubemap"
	"$envmaptint" "[ .1 .1 .1 ]"
	"$envmapconstrast" "1"

	"$phong"     "1"
	"$phongexponent"  "22"
	"$phongboost"   "1"
	"$phongfresnelranges"   "[1 .7 .3]"
	"$phongalbedotint" "1"
	"$phongwarptexture"  "Boba_Fett/shaders/phongwarp"
	"$lightwarptexture"      "Boba_Fett/shaders/lightwarp_bol"
	"$halflambert" "1"

	"$rimlight" "1"
	"$rimlightexponent" "4"	
	"$rimlightboost" "0.4"
	"$rimexponent" "1"
	"$rimboost" "0.4"
	"$rimmask" "Boba_Fett/shaders/mask"
}

I wondered about phong, cuz I read a thread on interlopers saying that phong didn’t have to be enabled. But my lightwarptexture works now that it’s on so I guess the thread was wrong = D
thank you!

[editline]15th December 2010[/editline]

I guess someone should flesh out the valve wiki page on lightwarps a little more.
Also, I’m using nocull because what I’m trying to do with this particular texture is make a model that will dynamically simulate an atmosphere surrounding a planet (spherical model) by being blue where it’s illuminated and black where it isn’t. I used nocull so the atmosphere would be illuminated from the outside (and on the correct side of the planet) and the resulting blue would be seen on the inside.
Thanks for helping and for providing such a thorough example = D