Limited amount of particles?

Hello, I’m in the process of making a few maps for myself, and of course looking at tutorials for new ideas.

Anyways, I came across this video: http://www.youtube.com/watch?v=TtnYNrPrmAY , which is about using Trigger - Precipitation.

In the video, you can see that he has plenty of particles rendering when he loads his map, however, when I put about the same amount of precipitation on my map, there are a lot less particles shown.
Here’s a SS: http://img339.imageshack.us/img339/5176/sighxk.png

The red box in the image shows where the ash is rendering, the blue shows where it’s supposed to render, but it isn’t unless I get really close.

Does anyone know how to get it to render all of the particles?

Did you set the density value to it’s maximum amount?

Yes, I have all of them set to 100, I even tried stacking multiple 100’s to make it more dense, but that still didn’t make any more show up, in fact, it only limited the distance at which the particles show even more.

Also, the same thing happens when I use func_dustclouds. I quickly added some to a map, and took some SSs of what’s happening.
http://img407.imageshack.us/f/72999777.png/ - What all the sides should look like if the particles rendered.
http://img821.imageshack.us/f/21027044.png/ - The second side, where way less particles render
http://img706.imageshack.us/f/41143615.png/ - The third side, where even less particles render
http://img253.imageshack.us/f/78872779.png/ - The fourth side, where no particles render at all, despite all the sides having the same settings and same amount of fun_dustclouds.

What texture do you use on the brush entities?

I always use a trigger texture, which works fine for me.

I use trigger for both of them, then change the properties to func_(insert here).

Do you think this is a problem with my game, or Hammer? Also, I’m using HL2, do you think CS:S would be any different?

EDIT: I just tried the same thing on CS:S and it’s the same thing.

Make a particle effect. Then you can have as many as 5000