[Linux] GMod doesn't launch - process stays alive

Hello there,

I haven’t started Garry’s Mod in a while, but I tried today and found myself unable to start the game. After the “preparing to start” dialog disappears, nothing further happens, but the hl2_linux process stays alive and it will show me as in-game until I kill it manually.

I’ve already tried reinstalling gmod, I renamed my GMod folder, told steam to delete the local content and re-downloaded the game. I did not do anything else(clean install), but it still didn’t start properly.

I have also tried it on a different computer, but got the same results.

Since it doesn’t work on either of my computers, which both run Linux, but it works for other people in my friends list, I think this may be a Linux-related problem. However, I have no idea how to even start debugging this.

How can I get it to work?

Any help will be greatly appreciated.

Kernel:
Linux 3.5.0-44-generic

Distribution:
Ubuntu 12.10 Quantal Quetzal

If you need any further information, please just ask.

I upgraded my Ubuntu to 13.10, which caused the game to start, but it didn’t find the client.so file.
I told my game to use the Beta (you can do that in the properties of Garry’s Mod), the game started successfully.

So, if you have the same problem, you know how to “fix” it now.