Linux Segmentation Fault

I’ve tried re-installing Garry’s Mod and even verifying all files and still won’t load. The server was working yesterday.

http://serverhostlab.com/bootfail.png

Test if u have the vphysics.so problem

test this file http://cpgs.cpanel.net/gm/vphysics.so at /orangebox/bin/

The file you posted will not download, it seems that you posted a file on cpanel when you were logged in.
Thanks for replying though.

Test this from wiki.garrysmod.de


cd ~
mkdir tmp
cd tmp/
wget http://dl.dropbox.com/u/759758/vphysics.zip
unzip vphysics.zip
cp vphysics.so ../scrds/orangebox/bin/vphysics.so

gz REJack

Linux is broken at the moment, try the binaries posted in this thread.

thx Drakehawke, this helps me self out.

ill help you off :wink:

Still getting a physics error, but the server didn’t have a segmentation fault this time. So glad it’s up thanks.

Edit: never mind, unable to pass getting the server information. I think this is where I was before the Segmentation fault. :frowning:

[editline]19th November 2012[/editline]

Does anybody know when this issue will be resolved? I’m trying to start a community group and this isn’t helping. I’ll probably just stick to CSS and other easier servers to manage.

I’m having the same problem when will this be fixed?

http://g.iriz.uk.to/~srcds/ob.tar.bz2

Download and extract that, copy it over your orangebox folder and overwrite all files.

You deserve a gigantic pat on the back. Thanks!

It stopped working after installing CSS content. I did reapply it. :frowning:

It fixed the error for me. But now I’m getting the “old” error with GLIBC (which the old binaries fixed)
What can I do about it?

To people that uses linux and still got errors after Drakehawke’s fix (as I did):

Extract the files in orangebox/bin/

That doesn’t work.

Hmm, I don’t think we have the same issue. It worked on my three servers.

Correct. I am getting


Failed to open dedicated_srv.so (./libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by bin/dedicated_srv.so))

But I have verified that I have the latest version.