[Linux server]Can not run TTT gamemode

System Details:
Ubuntu Server 11.04
Intel Xenon 3.2 GHz Quad
8gb memory
I ssh in to admin the server

So I am having issues loading the Trouble in Terrorist Town gamemode server side. When I launch, I get these errors: http://puu.sh/rXPa .

Files in terrortown gamemode folder http://puu.sh/rXR4 .
server.cfg: http://puu.sh/rXS9

Let me know if you need anything else. Not sure whats going wrong. I am loading a ttt map at launch.

[editline]28th April 2012[/editline]

and the rcon password has changed ooops

I’m having similar issues as well. I’m trying to run the elevator gamemode on my garrysmod server but it defaults to sandbox. I’ve tried adding the convars into the server.cfg file. I’ve also tried adding them to my startup line but that doesn’t seem to work either.

I’m running on Fedora 13, and here are my system specs.

processor : 7
vendor_id : GenuineIntel
cpu family : 15
model : 2
model name : Intel® Xeon™ MP CPU 2.20GHz
stepping : 6
cpu MHz : 2195.698
cache size : 2048 KB
physical id : 3
siblings : 2
core id : 0
cpu cores : 1
apicid : 7
initial apicid : 7
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe pebs bts cid xtpr
bogomips : 4390.29
clflush size : 64
power management:

Is anyone else able to get a different gamemode to work on linux aside from sandbox?

Linux, is not something of which likes GMod. Get windows.

I’m not running gmod itself on linux. I’m running a gmod DEDICATED server under linux. Which by the way works just fine, the only issue being that it doesn’t want to run anything other than sandbox.

But thanks for the kind suggestion. :slight_smile:

Linux works fine with Garry’s Mod. So does TTT for that matter (was just playing on one that was running on Linux).

OP: I can’t seem to load the links in the OP. If you can PM me your error log, I can help you with this.

Yeah links are dead, can you repost?

Windows, is not something of which likes stability. Get Linux.

I fixed some of the the ordinal issues. I needed to move the CS:S folder into the orangebox folder and change some permissions and in order to use terrortown town at launch I needed to add +sv_defaultgamemode “terrortown” to the start up line. I am still having some other issues which can be seen here http://puu.sh/sEob . This is my server.cfg file http://puu.sh/sEp9 . Basically when I load a map the weapon models to not load. I am getting some sourcemod error which I do not understand.

Sorry if I am slow to reply I am on a trip and internet is spotty.