Linux SRCDS; Others can't join

Ok, so here’s my issue.

I’m attempting to host a ZRP dedicated server with SRCDS. Simple enough, and for simplicity, I ran the server through a PC with Windows 7 installed. Forwarded the ports, and everything worked fine. Other’s could join, I could join, and was able to have around 8-10 people online without hitching my internet. But recently, my Win7 HDD began to fail, forcing me to switch to my backup Ubuntu HDD.

I downloaded and installed the Linux version of SRCDS, got GMOD and CS:S content, and tried to run the server again. It show’s up on the server list, and others can see it, but every time someone tries to connect, it says that the server is not responding/failed after 4 attempts.

Heres what I start the server with:
./srcds_run -console -game garrysmod -maxplayers 20 -tickrate 66 +ip [External IP] +port 27015 +exec server.cfg +mapzombiesurvival_b5.bsp +fps_max 255

I’m able to connect myself, so I’m guessing it has something to do with my network.

Any help would be appreciated.