Linux SRCDS Problem

Alright, every time I attempt to start the server, it crashes.

Command I run:
./srcds_run -console -game garrysmod +map mg_hellz_multigame_fix_b7 +gamemode minigame +maxplayers 28 -autoupdate -verifyall -debug

Results:

Updating server using Steam.
Checking bootstrapper version …
Failed to write output file ‘/root/Steam/stm4fb19a8b.TMP’
Mon May 14 23:51:39 UTC 2012: Steam Update failed, ignoring.
Running a benchmark to measure system clock frequency…
Finished RDTSC test. To prevent the startup delay from this benchmark, set the environment variable RDTSC_FREQUENCY to 2400.000000 on this system. This value is dependent upon the CPU clock speed and architecture and should be determined separately for each server. The use of this mechanism for timing can be disabled by setting RDTSC_FREQUENCY to ‘disabled’.
Using breakpad minidump system
Using breakpad crash handler

Console initialized.
failed to dlopen /root/srcds_1/orangebox/garrysmod/bin/server.so error=/lib32/libc.so.6: version `GLIBC_2.11’ not found (required by /root/srcds_1/orangebox/garrysmod/bin/server.so)
./srcds_run: line 372: 21174 Segmentation fault $HL_CMD
Add “-debug” to the ./srcds_run command line to generate a debug.log to help with solving this problem
Mon May 14 23:51:44 UTC 2012: Server restart in 10 seconds

I’m lost. I’ve looked around about where to find GLIBC_2.11, but can’t find anything.

Help?

It clearly says that they haven’t made SRCDS for Linux.

That’s Garry’s Mod 13, and it does work for Linux, but something is broken.



./srcds_run -console -game garrysmod +map mg_hellz_multigame_fix_b7 +sv_gamemode minigame +maxplayers 28 -autoupdate -verifyall -debug


Work ?

Gmod 13 works on linux? I dont think so, theres a reason gmod run on test binaries for linux, simply garry hate linux and wont make new updates for linux servers, sorry. At least i would be suprised if he suddenly decided to make updates for linux again.

You do realize I was talking about SRCDS on Linux, right? Anyways, killerrichard, that didn’t help at all.

You do realise i wrote

right?

What Linux Distro are you using?

http://www.facepunch.com/threads/1136364?p=33021297&viewfull=1#post33021297

and

http://www.facepunch.com/threads/1136364?p=33021297&viewfull=1#post33021297

Vehicle Fix:
http://www.facepunch.com/threads/1089190-Niggles-V2-while-true-do-annoygarry()-end?p=30729170&viewfull=1#post30729170

Assuming you have CentOS 5.X, just learned about this my self today :smiley:

Yeah, you can’t run srcds on any CentOS version older than 6.

Upgrade or switch distros to Ubuntu (my favorite)

Using Debian 5.0, any help?

update

You’ll need at least a newer Distro. I’ve never had issues with Ubuntu 11.04.