Listen server hosting problem

I was hosting my listen server without any problems, for several weeks (maybe months). I opened these ports:

1200; 27000-27015; 27020-27039; 26901-26901; 27016-27019 (all TCP/UDP)

But recently, my game crashed, leaving no error message. And I didn’t start the server again that day. The next day it just wasn’t working and my friends couldn’t connect. I tried to disable my firewall but no help. The IPs in my ipconfig seem to be the same ones, but strangely, both CSS and GMod isn’t working.

I checked my ports online and none are opened, my router is Zyxel P-660HW-T3 v2. The IP at my ports is the IPv4 one

did your local IP change on the router? You have to forward your ports to a specific IP such as… If your router reset, or if you unplugged it, you may have gotten a new IP on your router such as ..2.112 in which case you would need to update your port forwarding.

Yes, that is correct. I have a program that resets my ip to be static, so that I never have issues like this.

But the IP is still same, I checked in ipconfig. I have all the ports set on an IP looking like 10.0.x.x, the IP you’ve written (192.168…) is more likely how my external IP looks like. And I tried to set the ports on all the IPs I found and checked their accessibility on my external IP, but none worked…

192.168.x.x are Router Local IPs. Those are not External IPs.

I looked up that model that you gave us in the OP. Dude… That’s called a Modem. It makes a bit of difference on how things work. You are directly connected to the internet… not through a router which hooks into a modem like we thought. Sadly I never have set up Port Forwarding on a modem because our ISP provides us the modem, which is this POS out-of-date Surfboard modem with only 1 port, so there’s not much to forward - its just open or isn’t.

I can’t get a manual for it either. Found a few but the pages never load for me and eventually get a connection reset.

Jesus christ dude… Where’d you buy this thing? I want one.

Well I am not quite educated in this, I don’t even know what is the difference between a modem and a router. But on it says that my external adress is just random numbers. So I thought it’s my external IP… But the things in ipconfig are looking really simple, like, to which I had my ports binded when it worked.

So any conclusion? Should I just restart my rounter again and see for changes or what

something like can tell you your external IP if you are still confused as to whether or not its a local or external IP. Once you know whats what, you can go from there.

Yeah I already said that… Whatismyip, the router menu and the page you sent me, all are just telling me the same (external) IP. And I haven’t said that I don’t know what my external IP is, so why are we still turning around this? You maybe misunderstood from that I said it looks like random numbers. I meant it’s more like 45.175.xx.xx (random), but not so simple and rememberish like my (internal?) IP-, or the second one which I had filled at my ports when it worked-

On Windows, when I did ipconfig at console, it showed me the at one line and on another, so I tried to edit the ports IPs from …1 to the …2, which didn’t work. Here on Linux, the ipconfig (ifconfig) is showing me only the …2 adress reported as ‘inet’, but there is also one called maybe “allway” when translated from my language, and is written as

By the way, do I need to have my GMod MP game running when checking the ports? I tried to check all the ports with their corresponding IPs set to …2, with my game on, but it still reported them as closed

How else are you going to get a response? You have to be listening to get a response. You cant just get a response from nothing. You need to be running the server, not the game.

Use DMZ Hosting, it is more efficient, but it can have certain risks.

Thanks, I will try!

By the way sorry for some inactivity, I bought the Killing Floor from the humble bundle and played it a lot with friends, such an epic game! And I tried Garry’s Mod yesterday (the 160), but everything was broken like hell- every single addon was lagging for me, toolgun spawn effect was slow like hell (for the first time ever, for me), and SCars weren’t working at all. So I hope that everything is fixed with the 161, will try the DMZ tomorrow and report!

Just a note… if DMZ works, then you set up your ports wrong. :suicide:
Even though I use DMZ (Because I’m too damned lazy to update it every-time I get a new program) I still wouldn’t recommend it if you can get port forwarding set up correctly.

Now it’s fixed. I haven’t used DMZ, just updated all the ports to the new IP, the I don’t know why it didn’t work before, but it suddenly does now!

Sorry for reviving but I really need to fix it properly. Since it fixed I was able to host for several days, weeks… Then for one or two days it got down, and after that it fixed. Now I can’t host again, for no reason I could find. I think this “random shutdown” has happened more times, but it’s really irritating me. We just want to have a nice, sunny friday spent at GMod but we can’t, so I must end up at reading my fav books! Isn’t that silly?

I’ve restarted the modem several times but it still worked afterwards, so it isn’t by that. Yesterday it worked, today it doesn’t. Isn’t it occuring because of the IP randomly changing, because I haven’t paid for the statical thingy? Or someone decided to host on a same IP, if it’s even possible? Sometimes my friends even saw the as my server IP, but usually the external one.

Wouldn’t the program for a statical IP fix it? Or is it only for the router restarts? If you mean then no, I can’t find my router in their list. The program wasn’t properly working for me anyways

Have you shut down ALL your hardware and waited a bit?
It is impossible someone could be hosting on your ip by the way; it’s just how things work.

There are one very simple way to obtain a static local IP-Address.

  1. Open CMD and type ipconfig (Start>Search for cmd and press enter)
  2. Remember your IPv4-Address, Standard-Gateway and Sub-net Mask.
  3. Right-Click your network in the status bar and click “Open Network and Sharing Center”
  4. Click “Change adapter settings”.
  5. Right-Click Local Area Connection and select Properties.
  6. Find “Internet Protocol Version 4 (TCP /IPv4)” in that list and click it and then click Properties.
  7. A new window will pop up. Select “Use the following IP-Address” and enter your IPv4 Address, Subnet mask and Default Gateway (Standard Gateway from ipconfig).
  8. Use Google’s DNS Servers by pressing “Use the following DNS server addresses” and entering these values:
    Preferred DNS Server:
    Alternate DNS Server:

And violla! You’re done. You now have a static local IP-Address that will never change. (If you decide to move your computer to a friends house or something, you have to obtain their standard gateway, subnet mask (Which is often the same) and IP-Address, otherwise you won’t get access to the internet.)

Two more things you have to do:
Re-forward your ports to your new IP-Address (If you haven’t already. You will only have to do this once).
Find your external IP address:

Now send the external IP-Address+Port to your friends. Example:

Hope this helps.