Listen server port problem - GM13

Hello.

I used to host a listen server with a NETGEAR router with the ports 27015 & 27005 (if I remember correctly) both UDP/TDP.

Now, since the NETGEAR router’s ability to provide wireless signal went out, I can no longer use it. Thus, I got a new one. I searched the ocean of Google for answers before, during, and after the process of [trying] making a listen server work again.

My current router is a DLINK DIR-165 — Firmware Version : 9.00NA , 25, Nov, 2011 —

This is what the control panel for port forwarding looks like with my current settings. I DID use the following: 27015 & 27015 , 27015 & 27005.

Put 27015 in the TCP list. Scrap the 27000 port, you only require 27015 to host a server.

UDP is useless for GMod servers. Port forward TCP only to 27015. Also, make sure you’re using the right local IP.

[editline]21st March 2014[/editline]

Ninja’d

We’re Help & Support rivals you know ;D

Although you’re prolly in the lead by 3000 posts :zoid: (Btw, you can login to the IDE now, you went offline on Steam for some reason all suddenly :P)

I use the IPv4 for the IP adress area. Is that where I go wrong?

If you’re referencing an internal IP address (192.168.X.X) that won’t matter

Okay…

Anyone have an answer that will help?

Use the IPv4 address that you got from the ipconfig command in the cmd.

Btw, rating dumb on those who help you is not really a smart move.

I did what you told me with the 27015 only and used IPv4 adress. My friends say the server is not responding when they try to join my game.

Second,
I rated dumb on the ones that didn’t help me and didn’t abide to my question.

Can you take a screenshot of what your CMD says after typing in ipconfiig, and an updated picture of your port forwarded?

Also, do you play on the same computer you host from? If so, you may have to use 27016 instead for your server.

Also, make sure you have disabled all firewalls/antiviruses, they might block your traffic.

I host from my computer, yes.

Here is the CMD

Here is the CURRENT settings on my router for PF

Port forward port 27016 instead and put -port 27016 in your startup.bat.

Can you walk me through that .bat part?

How do you launch your server?

I start GMod > Start New Game > Change the amount of players to 8 (to make listen server) > Start Game

EDIT: Another issue, every time I restart my router to make changes like you told me to, my IPv4 changes. How can I fix this aswell?

EDIT2: My friends still cannot join, they say it says not responding. Any help? Please!

  1. Use dedicated server, not listen server.
  2. You’ll have to make a static IP. Google that.

I made the Dedicated. How do I join it?

For you, go to local servers on your server browser.

OKay, I am able to join my own game. However, my friends still cannot.

When I did the connect <ip adress>, GMod console gave me this error in console.



WARNING: Port 27015 was unavailable - bound to port 27016 instead
WARNING: Port 27005 was unavailable - bound to port 27006 instead
WARNING: Port 27020 was unavailable - bound to port 27021 instead


I don’t understand, I thought I forwarded the 27015?